Zigbee2MQTT not starting with "Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)"

Gosh. That did it. I feel little silly having spent 2 days on it! Thanks so much.

1 Like

I picked up on the original topic by Enzo on Github. But the responses are indeed pale.
I have been struggling for 2 weeks. Do you allow me to take over this topic?
Since I have the exact same configuration, the exact same log. And I tried the exact same things.
ZHA is not active in the integrations panels. It was initially, but I immediately removed it.

If I uninstall the mqtt broker and the zigbee2mqtt addon, I don’t see a ZHA discovered integration popping up. That’s seems odd.

I flashed the Sonoff zigbee dongle 3.0 with this file:

I used Flash Programmer 2 by TI. It was shown as succeeded.

The usb stick is visible in the log of HA and in the hardware section.
I defined the port in serial by looking at hardware and using the serial by id version.

I’m out of ideas. I might need some help.

Your link is pointing to “router” version of the FW. You should chose the “coordinator” version.
Edit: I also believe you link is wrong, might be me. There are many simple installations methods, search for it. I use the FW from this link.

1 Like

oh my god, dude. I’m deeply ashamed.
You are completely right; in 5 minutes I’m connected and up and running.
I did install the wrong FW (router). It should have been the coordinator.
Yet, I have to say that there are multiple tutorials on the internet saying that you should use the router FW.
This took me 12 hours. Aaargh.

Happy it works. If your first zigbee network, read some of the comments on how to avoid interference, like long usb extender cable and good distance to Wi-Fi devices.

1 Like

Hi Everyone.
I had the same issue as above. I’ve tried many things but no luck. I didn’t want to update the firmware on my ZBDongle-E. Finally I’ve found the solution and it works.
The main confusion is that ZBDongle-E uses different chip Silicon Labs EFR32MG21 which uses Zigbee Stack EmberZNet (EZSP v8). Please check ITead’s “Sonoff Zigbee 3.0 USB Dongle Plus V2” (model "ZBDongle-E") based on Silicon Labs EFR32MG21 +20dBm radio MCU now sold for $19.99
In the error log for Zigbee2MQTT it clearly mentioned Zstack, which is other option.

That being said, after explicitly specifying adapter: ezsp Zigbee2MQTT started successfully.
Check this option here Adapter settings | Zigbee2MQTT

Please check and let me know.

My config is below.


love you. that helped me. thx a lot

1 Like

big, big hug from my side!

the adapter value has resolved my issue :slightly_smiling_face:

Many thanks

Thank you!
Took your advice. Solved the problem.

Do you all mind if I revive this post?

I’ve been having problems with Zigbee2MQTT for months now.
The network would randomly drop and I would have to restart the Z2M addon in HA daily.

Now the addon won’t start at all

Setup: HA hassio as VM on Proxmox
Zigbee dongle the Electrolama zzh with latest firmware flashed
Dongle is connected via USB 3 extension cable an passed through to VM
Config pointing to /dev/serial/by-id/…

I’ve reseated the USB dongle, swapped the cable
Removed and readded the USB passthrough
Verified the USB in HA terminal and VM terminal

[22:16:15] INFO: Preparing to start...
[22:16:15] INFO: Socat not enabled
[22:16:16] INFO: Zigbee Herdsman debug logging enabled
[22:16:17] INFO: Starting Zigbee2MQTT...
Zigbee2MQTT:debug 2023-03-29 22:16:20: Loaded state from file /config/zigbee2mqtt/state.json
Zigbee2MQTT:info  2023-03-29 22:16:20: Logging to console and directory: '/config/zigbee2mqtt/log/2023-03-29.22-16-20' filename: log.txt
Zigbee2MQTT:debug 2023-03-29 22:16:20: Removing old log directory '/config/zigbee2mqtt/log/2023-03-29.22-10-00'
Zigbee2MQTT:info  2023-03-29 22:16:20: Starting Zigbee2MQTT version 1.30.2 (commit #unknown)
Zigbee2MQTT:info  2023-03-29 22:16:20: Starting zigbee-herdsman (0.14.96)
Zigbee2MQTT:debug 2023-03-29 22:16:20: Using zigbee-herdsman with settings: '{"adapter":{"concurrent":null,"delay":null,"disableLED":false},"backupPath":"/config/zigbee2mqtt/coordinator_backup.json","databaseBackupPath":"/config/zigbee2mqtt/database.db.backup","databasePath":"/config/zigbee2mqtt/database.db","network":{"channelList":[25],"extendedPanID":[221,221,221,221,221,221,221,221],"networkKey":"HIDDEN","panID":6754},"serialPort":{"path":"/dev/serial/by-id/usb-Prolific_Technology_Inc._USB-Serial_Controller_D-if00-port0"}}'
2023-03-30T02:16:21.027Z zigbee-herdsman:adapter Failed to validate path: 'Error: spawn udevadm ENOENT'
2023-03-30T02:16:21.029Z zigbee-herdsman:controller:log Starting with options '{"network":{"networkKeyDistribute":false,"networkKey":[1,3,5,7,9,11,13,15,0,2,4,6,8,10,12,13],"panID":6754,"extendedPanID":[221,221,221,221,221,221,221,221],"channelList":[25]},"serialPort":{"path":"/dev/serial/by-id/usb-Prolific_Technology_Inc._USB-Serial_Controller_D-if00-port0"},"databasePath":"/config/zigbee2mqtt/database.db","databaseBackupPath":"/config/zigbee2mqtt/database.db.backup","backupPath":"/config/zigbee2mqtt/coordinator_backup.json","adapter":{"disableLED":false,"concurrent":null,"delay":null}}'
2023-03-30T02:16:21.030Z zigbee-herdsman:adapter:zStack:znp:log Opening SerialPort with {"path":"/dev/serial/by-id/usb-Prolific_Technology_Inc._USB-Serial_Controller_D-if00-port0","baudRate":115200,"rtscts":false,"autoOpen":false}
2023-03-30T02:16:21.048Z zigbee-herdsman:adapter:zStack:znp:log Serialport opened
2023-03-30T02:16:21.050Z zigbee-herdsman:adapter:zStack:znp:SREQ --> SYS - ping - {"capabilities":1}
2023-03-30T02:16:21.051Z zigbee-herdsman:adapter:zStack:unpi:writer --> frame [254,0,33,1,32]
2023-03-30T02:16:35.029Z zigbee-herdsman:adapter:zStack:znp:SREQ --> SYS - ping - {"capabilities":1}
2023-03-30T02:16:35.034Z zigbee-herdsman:adapter:zStack:unpi:writer --> frame [254,0,33,1,32]
Zigbee2MQTT:error 2023-03-29 22:16:41: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2023-03-29 22:16:41: Failed to start zigbee
Zigbee2MQTT:error 2023-03-29 22:16:41: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
Zigbee2MQTT:error 2023-03-29 22:16:41: Exiting...
Zigbee2MQTT:error 2023-03-29 22:16:41: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
    at ZStackAdapter.start (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/zStackAdapter.ts:103:27)
    at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:132:29)
    at Zigbee.start (/app/lib/zigbee.ts:58:27)
    at Controller.start (/app/lib/controller.ts:101:27)
    at start (/app/index.js:107:5)

Any guesses on what to try?

I’m up for buying a new dongle if need be.
Might even pony up for a HA Yellow if it’s more stable.


Have you got any other zigbee network? In my case, I use 2 xiomi gateway3 with Mi home, and I bought SLZB-06 adapter. I config it with Zigbee2MQTT. It works for 10-15 minutes, and NEW zigbee network don’t work. Restart adapter, restart HA, and works for 10-15 minutes again. So, I turn off my old zigbee network (xiaomi gateway3), and test again. And the new zigbee network has been working ever since.
The zigbee default channel is 15. So, If you operate multiple zigbee networks (or your neighbor), you have to put them on different channels.

This worked for me too! Well done and thanks.

I only have one Zigbee network. It seems for some reason it’s not even recognizing the USB adapter path anymore, unless that’s just a default error.

Thank you! :slight_smile: that did it to me!

Thank you! This ezsp also works for the Home Assistant’s SkyConnect Dongle.

This worked for me too! Thank you so much :smile:

Yes,it is work for me,thank you very much :grinning_face_with_smiling_eyes:

So, to confirm, I can’t have ZHA and Z2M running concurrently, even with two separate dongles?

You can have ZHA and Z2M running concurrently, only with two separate dongles.