Zigbee2Mqtt Power_on_behavior

Hello everyone,

I use zigbee2mqtt in conjunction with the mosquito Broker:

I have a Philips Hue white and color ambiance E27 (9290024688) and a normal Hue white (8718696449691) with the current firmware 1.116.3 and would like to adjust the switch-on behavior when the lamp was without power and is switched on again. Previously I had set this up with a Hue Bridge and it worked perfectly. Now I’ve switched to a Raspi5 with homeassistant and the sonoff stick.
In Z2m I can set the Power-on behavior setting to “previous”. This setting is also adopted in the log, but the last state is not adopted after switching off and on again, but lights up again at full brightness.
This is the case with both lamps. .
With the Hue white and color ambiance E27, there is also the option for Color temp startup in Z2m. I can change this and it takes over. And also after switching off/on.

I can’t explain why it doesn’t work with the brightness setting?
Does anyone have any ideas?

English only over here

Just adjusted it. Sorry

It looks like using the “previous” power-on behavior isn’t working or sufficient.
You also need to set "hue_power_on_behavior": "recover" via MQTT.

I have now set via terminal
mosquitto_pub -h -p 1883 -t zigbee2mqtt/Test/set -m ‘{“hue_power_on_behavior”: “recover”}’ -u your_username -P your_password

and it works.
Thank you very much.