ZigBee2MQTT (RaspBee II) not working after SSD transition - yes I really tryed it all :(

Hey there,

I just transitioned from SD card to SSD on my RasPi4 with RaspBee II as ZigBee adapter.
After restoring my Backup everything works fine except Zigbee2MQTT…
Of course I did the research and here is what I´ve tried already:

  • Use long USB cable for SSD
  • Use powered USB-Hub
  • Try all USB-Ports
  • and I even used 2 sets of jumper cables to move the RaspBee II further away from the RasPi, so now my setup is positioned like this on my desk:

RasbBee II --------0,5m/19in Jumper cable ------- RasPi4 -------- 1m/40in USB cable --------- SSD

These are all the possible Solutions I could find so I would really appreciate your help guys!

Edit: I remember having the same error once before after a power outage but all I did to resolve this was doing several reboots and this didnt help so far…

Edit2: I put the RasPi in between 2 aluminum dishes with the RaspBeeII hanging out but the error stays the same…

Edit3: Disconnected SSD, booted from SD = everything works; connected the SSD and rebooted z2MQTT = still works…

Edit4: Updated the Firmware on the RaspBee II but still the same error

Log (repeating):

Zigbee2MQTT:error 2022-03-26 18:42:38: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2022-03-26 18:42:38: Failed to start zigbee
Zigbee2MQTT:error 2022-03-26 18:42:38: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
Zigbee2MQTT:error 2022-03-26 18:42:38: Exiting...
Zigbee2MQTT:error 2022-03-26 18:42:38: undefined
[18:42:38] INFO: Handing over control to Zigbee2mqtt Core ...
> [email protected] start
> node index.js


data_path: /config/zigbee2mqtt
external_converters: []
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: false
  base_topic: zigbee2mqtt
  port: /dev/ttyAMA0
  adapter: deconz
  log_level: warn
  pan_id: 6754
  channel: 11
    - 1
    - 3
    - 5
    - 7
    - 9
    - 11
    - 13
    - 15
    - 0
    - 2
    - 4
    - 6
    - 8
    - 10
    - 12
    - 13
  availability_blocklist: []
  availability_passlist: []
device_options: {}
blocklist: []
passlist: []
queue: {}
  port: 8099
experimental: {}
availability: false
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: '-d -d'
  log: false

UserInterface → Supervisor → Hardware → TTYAMA0:

DEVLINKS: /dev/serial1
DEVNAME: /dev/ttyAMA0
DEVPATH: /devices/platform/soc/fe201000.serial/tty/ttyAMA0
MAJOR: '204'
MINOR: '64'
TAGS: ':systemd:'

Hey there, I hope I can help you with my experience!
I had the same issue for the last weeks, until I found out, the SSD is creating the interference
(since WiFi, ZigBee, Bluetooth and many other standards use the 2.4Ghz frequency. …as you already know)
My Zigbee dongle already had an 1m extension, which did not help.

What helped me now is:

  1. adding a 2m extentions for my zigbee dongle (conbee II)
  2. wrapping my ssd and it’s usb cable in aluminium foil.

My Zigbee devices are now all back on track, … next up are my bluetooth devices ^^’
The other day I read about usb3/ssd interferences in submarines, which can lead to deadly problems… so I see my problems as minor.

I wish you the best of luck!

I’m having the same problem
Did you get this working?

update: 2m extension worked for me