Zigbee2mqtt refuses to add zig devices with Sonoff zig 3 usb dongle

got myself the sonoff zigbee 3 usb dongle plus from amazon. i have not flashed any firmware. i just plugged into my hassOS and everything seems to be fine as seen here in the log:

in the Z2m web interface, i clicked on Permit to join and it looks like a timer countdown:

but Z2M refuses to see any of my zig devices…
(these devices worked fine with ZHA before but with the Nortek usb combo stick)

so what’s the trick to adding my devices?
in my config, the only thing i changed was the network key, i swapped some of the numbers around. and the zig channel is 25, instead of 11.

  • use an USB extension cable
  • use an USB 2 port
  • update to the latest firmware

And just in case that it’s not clear: You need to re-pair each and every one if your Zigbee devices to the Sonoff coordinator.

1 Like

the dongle is on a 10feet usb2 extension cable that’s connected to the macbookpro 2010’s usb 2 port.
let me try the latest fw today. thanks

While you are at it, read and follow the related general tips in https://github.com/home-assistant/home-assistant.io/pull/18864 and https://www.home-assistant.io/integrations/zha#best-practices-to-avoid-pairingconnection-difficulties as all Zigbee Coordinator adapters is very sensitive to EMI/RFI interference (e.g. a noisy radio frequency environment will jam the signal and prevent it from receiving all Zigbee messages to it without errors).

PS: If it help give a thumbs up in https://github.com/home-assistant/home-assistant.io/pull/18864

You need to actively re-pair all your Zigbee devices. Did you do this?
(They will not show up on your new Zigbee network even if they worked before without re-pairing to the new Coordinator.)

ok. the re-pair did not work. i had to factory reset. then re-pair work. all good now. thanks!