Zigbee2mqtt: show the networkmap in home assistant

The source.js file is created every time you call the service. Since the MQTT message is successfully published by zigbee2mqtt, I assume it is due to missing permissions.

Of course, I used the old path. :man_facepalming:
I should not be troubleshooting 1 o’clock in the morning.
It works now. Thank you


I appear to be having an issue with displaying the actual map.
I believe I’ve no issues generating the required data, based upon the logs

  zigbee2mqtt:info 8/14/2019, 8:50:19 AM Starting network scan includeRoutes='0'...
  zigbee2mqtt:info 8/14/2019, 8:50:19 AM Network scan completed
  zigbee2mqtt:info 8/14/2019, 8:50:19 AM MQTT publish: topic 'zigbee2mqtt/bridge/networkmap/graphviz', payload 'digraph G {
  "0x00124b001938f0b3" [style="bold, filled", fillcolor="#e04e5d", fontcolor="#ffffff", label="{0x00124b001938f0b3|0x0 |No model information available|online (2019-08-14T08:50:19+01:00)}"];
  "0x00124b001938f0b3" -> "0xd0cf5efffeed648e" [penwidth=0.5, weight=0, color="#994444", label="80"]
  "0x000d6ffffe483dc3" [style="rounded, filled", fillcolor="#4ea3e0", fontcolor="#ffffff", label="{0x000d6ffffe483dc3|0xe2fb |IKEA TRADFRI LED bulb GU10 400 lumen, dimmable, white spectrum (LED1537R6)|online (13:11:50s ago)}"];
  "0x000d6ffffe483dc3" -> "0x00124b001938f0b3" [penwidth=0.5, weight=0, color="#994444", label="1"]
  "0x000d6ffffe483dc3" -> "0xd0cf5efffeed648e" [penwidth=0.5, weight=0, color="#994444", label="255"]
  "0xd0cf5efffeed648e" [style="rounded, filled", fillcolor="#4ea3e0", fontcolor="#ffffff", label="{0xd0cf5efffeed648e|0x2c54 |IKEA TRADFRI LED bulb GU10 400 lumen, dimmable, white spectrum (LED1537R6)|online (13:11:50s ago)}"];
  "0xd0cf5efffeed648e" -> "0x00124b001938f0b3" [penwidth=0.5, weight=0, color="#994444", label="31"]
  "0xd0cf5efffeed648e" -> "0x000d6ffffe483dc3" [penwidth=0.5, weight=0, color="#994444", label="255"]
  zigbee2mqtt:info 8/14/2019, 8:50:22 AM Network scan timeout no outstanding requests

I’ve also taken the generated source.js and used http://viz-js.com/ to display the file, which generates as below:

However, Home Assistant display a blank map on the Zigbee Map tab.

I think that’s also due to missing write permissions.
I would expect an error message in the Homeassistant log in such cases…

Thanks for the advice, but not seeing anything in the Home Assistant main log and the Zigbee2MQTT log is as I previously posted.

Which file are you suggesting the permissions error is, as obviously it appears to be writing to the .js?


Hi guys, not sure if this has been mentioned here already, I didn’t see it, but check out this tread: https://community.home-assistant.io/t/zigbee2mqtt-lovelace-custom-card-to-show-zigbee2mqtt-network-map
This is plugin that gives a really neat representation of the zigbee network.

I had this same issue… but the cause may not be the same for you… But essentially, I had migrated from a self-install to a Hass.IO + HACS install and what I found was that the map would never update. What i realized was that the data was being sent to the old self-installed version. I just deleted the old directory, uninstalled the HACS version, restarted and reinstalled and everything works now.

For some reason the iframe is not visible (not even on the menu)
Where should I be looking? The configuration.yaml looks OK - direct copy and paste from OP

1 Like

Have you called the service? No error in log?

Ah, seems I had a space after panel_iframe:
One step forward! Now getting a blank iframe but I see some stuff above. Thanks @robin

I’m new to this, so the number represents the signal strength or how close it is to the router? For example if it shows 1, is that a weak signal strenght or is that how close it is to the router?

It means too weak signal strength. You need to move it closer to your zigbee hub or place some more zigbee router between your end device and zigbee hub

1 Like

Hello. Can you please help me?
I am using zigbee2mqtt 1.4.0. The directory of the component looks like this:

I put this in my configuration.yaml:

   #topic: your topic (optional, default zigbee2mqtt)
     title: 'Zigbee Map'
     url: '/local/zigbee2mqtt_networkmap/www/map.html'
     icon: 'mdi:graphql' 

After the restart of hassio nothing happens. No errors in the logs. No new menu items. Nothing.
Also map update serice is not found:

Also I have tried to put component’s directory to the custom_components folder. But nothing changed.

Follow the instructions. It tells you where to put the component.

Hello everybody,

The time format is not right …
What can i do?



My map looks very different. It’s full colour and I don’t get interconnecting lines.
I’m using latest version of zigbee2mqtt development branch.
My network is quite old from when zigbee2mqtt was fairly fresh, I wonder if I need to update the firmware and start my zigbee network again from scratch?

Hi everyone,

I have a lot of unconnected devices:

In example

However, device is connected and information is comming trough:

Is there something wrong with my mesh network?
Or is there something wrong with the zigbee2mqtt software?

Kind regards,
Bart Plessers


  • Zigbee2mqtt on bare-metal RPI
  • CC2531_USB-stick
  • latest version: CC2531_DEFAULT_20190608.zip

have you set the correct time zone in your home assistant configuration?

i also had the problem with the missing links after a firmware update. it only helped to pair my devices new


I also think that the firware is too old.
How can I update it?

runs under container station QNAP ( Docker)