Zigbee2mqtt: show the networkmap in home assistant

Sorry guys, I’ve been really busy the last few months. I just committed some tweaks from codewise-nicolas.Please check if your problems are still present.

I had no problems before but after I installed the update now I get a blank page when opening the map.

HA says this:

…but my config is exactly what the readme file says, even including the comment:

  #topic: your topic (optional, default zigbee2mqtt)
    title: 'Zigbee Map'
    url: '/local/community/zigbee2mqtt_networkmap/map.html'
    icon: 'mdi:graphql'

I installed it through HACS if that makes any difference.

Edit: Ah, turns out the update script failed because I had already moved a file manually after the addon initially didn’t do that by itself:

2020-03-30 18:15:16 ERROR (MainThread) [homeassistant.setup] Error during setup of component zigbee2mqtt_networkmap
Traceback (most recent call last):
File “/usr/local/lib/python3.7/distutils/dir_util.py”, line 70, in mkpath
os.mkdir(head, mode)
FileExistsError: [Errno 17] File exists: ‘/config/www/community/zigbee2mqtt_networkmap/viz.js’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/setup.py”, line 170, in _async_setup_component
hass, processed_config
File “/config/custom_components/zigbee2mqtt_networkmap/init.py”, line 25, in async_setup
copy_tree(fromDirectory, toDirectory)
File “/usr/local/lib/python3.7/distutils/dir_util.py”, line 159, in copy_tree
verbose=verbose, dry_run=dry_run))
File “/usr/local/lib/python3.7/distutils/dir_util.py”, line 135, in copy_tree
mkpath(dst, verbose=verbose)
File “/usr/local/lib/python3.7/distutils/dir_util.py”, line 74, in mkpath
“could not create ‘%s’: %s” % (head, exc.args[-1]))
distutils.errors.DistutilsFileError: could not create ‘/config/www/community/zigbee2mqtt_networkmap/viz.js’: File exists

After removing that file it works again.

I’m sorry, but these installation directions are just terrible. So many steps and details missing…

I’ve FINALLY gotten the iFrame to work and got rid of my 404 error. Now I’m trying to set up the Automation to call the service every 10 minutes. Guess what? The service “zigbee2mqtt_networkmap.update” doesn’t appear to exist. What non-existent step did I miss?

1 Like

I take it you are volunteering to document it. Well done.

1 Like

If I could ever get it to work, sure…

Well post a proper request for help then. See How to help us help you - or How to ask a good question

Out of interest, what steps do you think are missing?

The steps on where to extract the files from the zip archive are unclear. You’ll see that several people had the 404 error because of this.

Second, what prerequisites are necessary? When I installed the integration through HACS, made the change to the configuration.yaml file, extracted the zip, and restarted HA I received a notification on startup that mqtt and Zigbee2mqtt were invalid and as I mentioned there was no Zigbee2mqtt service to create an automation for. Am I supposed to install mqtt somehow first?

I apologize if I came off as rude but I’m new to HA and as I dive in I’m finding that a lot of assumptions are made that people know all these things. I understand this is more complicated and involved than say SmartThings, but it is difficult and a little frustrating. It’s kind of a theme across the Linux community in general.

Finally, the code snippets provided for the configuration.yaml won’t work if you simply copy and paste as the indentions are off. At least it threw an error for me until I fixed the spacing.

1 Like

Well quite clearly you’ll need zigbee2mqtt before you even begin to show the zigbee2mqtt network map. You cannot see the network map of something you don’t have!

And yes zigbee2mqtt needs mqtt.

Perhaps you misunderstood what this custom component does?

Ok, I wanted to give this a try.
TL;DR: in 5 minutes I had this:


This is my system:

arch	x86_64
dev	false
docker	true
hassio	true
os_name	Linux
os_version	5.3.0-28-generic
python_version	3.7.7
version	0.107.6
virtualenv	false

My prerrequisites:

My steps:
1.- Search zigbee2mqtt in the Integrations tab in HACS:


2.- Click install (the screenshot shows reinstall because I’m writing this howto after installing it):


3.- I added this to my configuration.yaml :

  topic: zigbee2mqtt
    title: 'Zigbee Map'
    url: '/local/community/zigbee2mqtt_networkmap/map.html'
    icon: 'mdi:graphql'

It’s the same as in the instructions in the add-on but, as @cdef said, the indentations are off.

4.- Restart HA

5.- Go to Developers tools and run the zigbee2mqtt_networkmap.update service:


6.- Enjoy the map clicking in the sidebar:


Thanks to all the people that make this possible.

See, you mention these things that are “obvious” but how is someone new supposed to know what is actually being installed through HACS? I have no idea what zigbee2mqtt or MQTT are until I tried to get this map working to troubleshoot my zigbee mesh.

You use Google, same as I and hundreds of others do when they want to know something.

Thanks for the advice. Now some for you, if you’re going to get upset and act defensive because someone calls the instructions lacking, and your best response is to “use Google”, then you’re basically admitting that the instructions are lacking. Again, these prerequisites were never listed, how am I to know that they aren’t already part of HA or part of this integration?

I got my Zigbee issue resolved so no longer need this, so farewell and good luck with your defensive, dismissive attitude.

The instructions are not lacking, your level of understanding is lacking.

anybody has overlapping objects ?

Good Day Community,
I did follow the instruction given by
@timseebeck provided here and I am still getting a:
Invalid Config
The following integrations and plattforms could not be set up:

  • zigbee2mqtt_network

Also tried to get some more information in this forum. Some people pointed out that installing via HACS currently might be an issue. Which Files do I have to expect in the /www Folder? And where should I investigate?

I have this in the www/community/zigbee2mqtt_networkmap folder:


I only have two files

Any Idea anyone?

Try again installing through hacs.

I did uninstall, double check if the folders were cleaned up and then did a fresh installaiton through hacs.
Still I am getting the same error message. It als seems like the plugin is not executed since there is no map file generated. I am on HassOS 3.13 Supervisor 217 and HA 0.108.6. Help is appreciated.