Zigbee2mqtt: show the networkmap in home assistant

You use Google, same as I and hundreds of others do when they want to know something.

Thanks for the advice. Now some for you, if you’re going to get upset and act defensive because someone calls the instructions lacking, and your best response is to “use Google”, then you’re basically admitting that the instructions are lacking. Again, these prerequisites were never listed, how am I to know that they aren’t already part of HA or part of this integration?

I got my Zigbee issue resolved so no longer need this, so farewell and good luck with your defensive, dismissive attitude.

The instructions are not lacking, your level of understanding is lacking.

anybody has overlapping objects ?

Good Day Community,
I did follow the instruction given by
@timseebeck provided here and I am still getting a:
Invalid Config
The following integrations and plattforms could not be set up:

  • zigbee2mqtt_network

Also tried to get some more information in this forum. Some people pointed out that installing via HACS currently might be an issue. Which Files do I have to expect in the /www Folder? And where should I investigate?

I have this in the www/community/zigbee2mqtt_networkmap folder:


I only have two files

Any Idea anyone?

Try again installing through hacs.

I did uninstall, double check if the folders were cleaned up and then did a fresh installaiton through hacs.
Still I am getting the same error message. It als seems like the plugin is not executed since there is no map file generated. I am on HassOS 3.13 Supervisor 217 and HA 0.108.6. Help is appreciated.

Any chance to see your configuration.yaml file?

# Configure a default setup of Home Assistant (frontend, api, etc)

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: example.duckdns.org:8123

# Text to speech
  - platform: google_translate

automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml
sensor: !include sensors.yaml
timer: !include timer.yaml

#Zigbee2mqtt Networkmap
  topic: zigbee2mqtt
    title: 'Zigbee Map'
    url: '/local/community/zigbee2mqtt_networkmap/map.html'
    icon: 'mdi:graphql'

# Mqtt2Zigbee
    name: Allow devices to join
    initial: off
    icon: mdi:cellphone-wireless

Anything else required?

You seem to be missing webhook:


   #topic: your topic (optional, default zigbee2mqtt)
     title: 'Zigbee Map'
     url: '/local/community/zigbee2mqtt_networkmap/map.html'
     icon: 'mdi:graphql'

I don’t see anything related to MQTT in your config. It is the first prerrequisite I wrote here

If he did setup mqtt through the integration, it will not show in configuration.yaml.

Thanks for telling. Always learning.

I do have quite some sensors that have no connection line drawn. Even the last seen timestamp of the units is recent.
Currently affecting 8 sensors. Sometimes one of them gets a connection line, but mostly it’s the same sensors that dont get.
I do have 17 xiaomi sensors, 2 ikea lights, the 1352 cooridnator (and for testing a 2531 router which makes also no difference). Some are really near to coordinator.

Any ideas why?

So uninstalled through HACS and installed according to the manual provided by @Robin at the beginning of this thread and it works perfectly. Guessing rather an issue with the installation via HACS than the configuration.


Hello! could you help? looks like devices which connected to Xiaomi Zigbee Socket have shoven alone on the map. I have seen that issue but can’t understand how they fixed the problem. (zigbee2mqttassistant and zigbee2mqtt-networkmap.js the same)

Of course zigbee2mqttassistant and zigbee2mqtt-networkmap.js are the same, they get their information from the same source. If your devices work well, I would not worry about it.

1 Like