Zigbee2mqtt - sniffer stooped working after 4 or 5 days

Hi there,

I need your help with my CC2531 pen.
It was working in HASS.IO with zigbee2mqtt without any problems, in an RPi4, for a few days. I added a few zigbee devices (Ikea and a few others) and everything worked fine. The map also showed the mesh network they managed to create to reach more distant points of the house.

One day the pen stopped working. I didn’t made any updates that day or change the configuration.
When the zigbee-herdsman starts, the green light of the pen goes out and just removing and putting the pen back on again.

> [email protected] start /zigbee2mqtt-1.16.1
> node index.js
Zigbee2MQTT:debug 2020-12-03 09:39:12: Loaded state from file /share/zigbee2mqtt/state.json
Zigbee2MQTT:info  2020-12-03 09:39:12: Logging to console and directory: '/share/zigbee2mqtt/log/2020-12-03.09-39-11' filename: log.txt
Zigbee2MQTT:debug 2020-12-03 09:39:12: Removing old log directory '/share/zigbee2mqtt/log/2020-12-02.19-00-53'
Zigbee2MQTT:info  2020-12-03 09:39:12: Starting Zigbee2MQTT version 1.16.1 (commit #1.16.1)
Zigbee2MQTT:info  2020-12-03 09:39:12: Starting zigbee-herdsman...
Zigbee2MQTT:debug 2020-12-03 09:39:12: Using zigbee-herdsman with settings: '{"adapter":{"concurrent":null},"backupPath":"/share/zigbee2mqtt/coordinator_backup.json","databaseBackupPath":"/share/zigbee2mqtt/database.db.backup","databasePath":"/share/zigbee2mqtt/database.db","network":{"channelList":[25],"extendedPanID":[221,221,221,221,221,221,221,221],"networkKey":"HIDDEN","panID":6754},"serialPort":{"path":"/dev/ttyACM0"}}'
Zigbee2MQTT:error 2020-12-03 09:39:52: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2020-12-03 09:39:52: Failed to start zigbee
Zigbee2MQTT:error 2020-12-03 09:39:52: Exiting...
**Zigbee2MQTT:error 2020-12-03 09:39:52: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)**
    at ZStackAdapter.<anonymous> (/zigbee2mqtt-1.16.1/node_modules/zigbee-herdsman/dist/adapter/z-stack/adapter/zStackAdapter.js:94:31)
    at Generator.throw (<anonymous>)
    at rejected (/zigbee2mqtt-1.16.1/node_modules/zigbee-herdsman/dist/adapter/z-stack/adapter/zStackAdapter.js:25:65)

I changed the USB ports, turned off the RPI4 completely and in the meantime I connected a powered hub and connected it to the RPI4 and it’s the same.

The configuration of the add-on is practically the standard, just add the credentials of the MQTT broker and the channel that is suitable for the wireless network here at home.

data_path: /share/zigbee2mqtt
external_converters: []
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: false
  base_topic: zigbee2mqtt
  server: 'mqtt://<ip>:1883'
  user: <user>
  password: <password>
  port: /dev/ttyACM0
  log_level: info
  pan_id: 6754
  channel: 25
    - 1
    - 3
    - 5
    - 7
    - 9
    - 11
    - 13
    - 15
    - 0
    - 2
    - 4
    - 6
    - 8
    - 10
    - 12
    - 13
  availability_blocklist: []
  availability_passlist: []
device_options: {}
blocklist: []
passlist: []
queue: {}
  port: 8099
  new_api: true
  enabled: false
  master: 'pty,raw,echo=0,link=/dev/ttyZ2M,mode=777'
  slave: 'tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5'
  restartdelay: 1
  initialdelay: 1
  options: '-d -d'
  log: false

Does anyone have any ideas?
I don’t have the encoder to flash the pen again.


Flash the firmware to it again.

Thanks for your reply.
Is it normal for the pen to need flashing again?


I had a similar issue once, reflashed, no issues since. It only takes 5mins to do, so worth trying.

Yes, of course. However I still don’t have an encoder so I’ll try some help to do it while wait for the encoder.