Zigbee2mqtt starting issues after Migrating from sd to ssd

Need help please. Recently upgrade my rasberry 4 sd to ssd.
Start to have issues with loading of zigbee2mqtt add on.
Im using a doogle P.
A pop saying : Zigbee2MQTT

The add-on is not running. Do you want to start it now?

when click start on.


The add-on seems to not be ready, it might still be starting. Do you want to try again?
Unable to start it,
Theres a warning stating 502 bad gateway,

Zigbee had no issues before migration.
Eventhough unable to open zigbee2mqtt , the device in it can stiill be activated.

My config:
data path
enabled: false
master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
options: “-d -d”
log: false

base_topic: zigbee2mqtt
user: mqtt_user
server: mqtt://
port: >-

Log will show
[01:58:07] INFO: Preparing to start…
[01:58:08] INFO: Socat not enabled
[01:58:08] INFO: Zigbee Herdsman debug logging enabled
[01:58:10] INFO: Starting Zigbee2MQTT…


Refusing to start because configuration is not valid, found the following errors:

  • MQTT retention requires protocol version 5

If you don’t know how to solve this, read Configuration | Zigbee2MQTT


mine zigbee 2 mqtt version is 1.36.0-1

  • Updated Zigbee2MQTT to version [1.36.0]

24-03-24 02:15:47 INFO (MainThread) [supervisor.docker.addon] Starting Docker add-on zigbee2mqtt/zigbee2mqtt-aarch64 with version 1.36.0-1
24-03-24 02:15:47 WARNING (MainThread) [supervisor.addons.options] Unknown option ‘base_topic’ for Zigbee2MQTT (45df7312_zigbee2mqtt)
24-03-24 02:15:47 WARNING (MainThread) [supervisor.addons.options] Option ‘permit_join’ does not exist in the schema for Zigbee2MQTT (45df7312_zigbee2mqtt)
24-03-24 02:15:47 WARNING (MainThread) [supervisor.addons.options] Option ‘frontend’ does not exist in the schema for Zigbee2MQTT (45df7312_zigbee2mqtt)

Power down your pi (no reboot, power off), and restart.
Alsof, be sure to use an USB extension cable

already using an extension. power down did not solve the problem.

Change the server to:

server: mqtt://core-mosquitto (no port needed here)

And you’ll probably need the adapter type after the serial port. V2 of that adapter is:

adapter: ezsp

it is definitely not an ezsp

This could help if he is running the mosquitto add-on

Yup, you’re right, I misread the adapter type. Should be zstack.