Zigbee2mqtt - TRADFRI motion sensor


I have a number of devices - sensors, switches, blinds working through a USB stick using the zigbee2mqtt stack. This all works beautifully with one exception - I regularly have issues with the TRADFRI motion sensors (the white, battery powered PIRs) and cannot figure out what is going wrong. The integration often “breaks” when I upgrade HA and then gets fixed a few releases later. Currently, I am in the broken state and the symptoms are as follows:

  1. The PIRs remain visible on Zigbee2MQTT web page. HA also picks up the latest battery status which I proved by swapping old-for-new batteries

  2. The network map shows the devices as green endpoints and one of the PIRs is connected to an IKEA router which is connected to the stick. The network looks fine

  3. The device status also changes but with a huge lag (1 hour plus). When it works the response is instant - I can wave my hand over the sensor and HA knows immediately

  4. If I use MQTT explorer then I also see the topics but, again, there is no real-time flow from the device

Any pointers would be much appreciated.

Many thanks,


Have you checked in Z2M if there is a firmware update for it ? Mine are all working fine now. I did have trouble a while ago but it seems to have gone away, maybe after when I discovered how to update the firmware

EDIT: Scrap that, I don’t have any any more, replaced with sonoff and aqara

In my expirience, this is related to problem with router device over which sensor is connected. In my case it was xiaomi relay. You can try delete device from zigbee2mqtt with force delete, then pair it again over specific router device. This worked for me.

I agree with Igor, bad route or bad connection.

Hi Igor,

Thanks - I have started playing with this. The odd thing is that all three of my Ikea PIRs drop out. They behave perfectly then some HA update happens and they stop working. The drop-out means they just don’t trigger an event in real-time to the MQTT broker. Meanwhile other Ikea devices (blinds, switches) work fine.

I have just deleted one and re-paired it. This hasn’t fixed the issue but it has paired and, intermittently, sends an event. I will persist and try with the others and with different routing paths.

Kind regards,


All five of them have never dropped out


Mine don’t seem to be dropping out either. The symptoms are erratic detection of an event through Z2M. I have just tried with a new sensor. It pairs fine and shows on the map. The status is online but motion is sometimes detected instantly and other times not at all or only after a few minutes. If I press the buttons on the PIR then, again, there isn’t a direct response. If I watch on MQTT Explorer then it’s clear that there isn’t a message being received despite the PIR being triggered.

This state comes and goes and seems to be related to upgrading HA.