Zigbee2mqtt using virtualhere or ser2net

Cannot setup zigbee coordinator (electrolama zzh) on tcp (virtualhere or ser2net).
Running HA supervised on Debian VM from synology. The reason why I’m trying to use tcp is the virtual machine manager keeps randomly unmounting the USB key (a conbee II) which is unacceptable plus the zzh does not work through VMs.

Here is the important bits of my config
(using virtualhere)

  port: 'tcp://'
  rtscts: false
  enabled: false

I get

Error: Failed to connect to the adapter (Error: Cannot request when znp has not been initialized yet)

I’ve tried the z2m config found here
where socat is not mentionnend so I left it disabled
(using ser2net)

  port: 'tcp://'
  rtscts: false
  enabled: false

here is the result :

2021-03-24T12:13:18.668Z zigbee-herdsman:adapter:zStack:znp:log Opening TCP socket with
2021-03-24T12:13:18.681Z zigbee-herdsman:adapter:zStack:znp:log Socket connected
2021-03-24T12:13:18.683Z zigbee-herdsman:adapter:zStack:znp:log Socket ready
2021-03-24T12:13:18.685Z zigbee-herdsman:adapter:zStack:znp:log Writing skip bootloader payload
2021-03-24T12:13:18.686Z zigbee-herdsman:adapter:zStack:unpi:writer --> buffer [239]
2021-03-24T12:13:18.700Z zigbee-herdsman:adapter:zStack:znp:log Port closed
2021-03-24T12:13:19.693Z zigbee-herdsman:adapter:zStack:znp:SREQ --> SYS - ping - {"capabilities":1}
2021-03-24T12:13:19.697Z zigbee-herdsman:adapter:zStack:unpi:writer --> frame [254,0,33,1,32]
2021-03-24T12:13:25.705Z zigbee-herdsman:adapter:zStack:znp:SREQ --> SYS - ping - {"capabilities":1}
2021-03-24T12:13:25.708Z zigbee-herdsman:adapter:zStack:unpi:writer --> frame [254,0,33,1,32]
2021-03-24T12:13:31.715Z zigbee-herdsman:adapter:zStack:znp:SREQ --> SYS - ping - {"capabilities":1}
2021-03-24T12:13:31.717Z zigbee-herdsman:adapter:zStack:unpi:writer --> frame [254,0,33,1,32]
Zigbee2MQTT:error 2021-03-24 13:13:37: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2021-03-24 13:13:37: Failed to start zigbee
Zigbee2MQTT:error 2021-03-24 13:13:37: Exiting...
Zigbee2MQTT:error 2021-03-24 13:13:37: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
    at ZStackAdapter.<anonymous> (/app/node_modules/zigbee-herdsman/dist/adapter/z-stack/adapter/zStackAdapter.js:94:31)
    at Generator.throw (<anonymous>)
    at rejected (/app/node_modules/zigbee-herdsman/dist/adapter/z-stack/adapter/zStackAdapter.js:25:65)

I’ve also tried this config
(using virtualhere)

  port: /dev/ttyZ2M
  rtscts: false
  enabled: true
  master: 'pty,raw,echo=0,link=/dev/ttyZ2M,mode=777,end-close'
  slave: 'tcp:,ignoreeof'
  restartdelay: 1
  initialdelay: 1
  options: '-d -d'

here is the result :

Zigbee2MQTT:error 2021-03-24 15:17:29: Error: Error while opening serialport 'Error: Error: No such file or directory, cannot open /dev/ttyZ2M'
Socat startup parameters:
Options:     -d -d
Master:      pty,raw,echo=0,link=/dev/ttyZ2M,mode=777,end-close
Slave:       tcp:,ignoreeof
[15:17:30] INFO: Starting socat process ...
2021/03/24 15:17:30 socat[477] N PTY is /dev/pts/2
2021/03/24 15:17:30 socat[477] E unlink("/dev/ttyZ2M"): Read-only file system
2021/03/24 15:17:30 socat[477] N exit(1)

I’m pulling my hair out… Nothing works
Anyone has a suggestion ?

Thinking it might be the zzh stick at fault I tried with my old faithful conbeeII and it still does not want to work with virtualhere


  adapter: deconz
  port: 'tcp://'

I got

2021-03-24T14:52:03.901Z zigbee-herdsman:deconz:driver Opening TCP socket with
2021-03-24T14:52:03.915Z zigbee-herdsman:deconz:driver Socket connected
2021-03-24T14:52:03.917Z zigbee-herdsman:deconz:driver Socket ready
2021-03-24T14:52:03.917Z zigbee-herdsman:controller:log Started with result 'resumed'
2021-03-24T14:52:03.917Z zigbee-herdsman:controller:log Injected database: true, adapter: true
2021-03-24T14:52:03.919Z zigbee-herdsman:deconz:driver send read parameter request from queue. seqNr: 1 paramId: 1
2021-03-24T14:52:06.882Z zigbee-herdsman:deconz:adapter checking coordinator simple descriptor
2021-03-24T14:52:06.887Z zigbee-herdsman:deconz:driver DATA_REQUEST - destAddr: 0x0 EP:0 SeqNr. 2 request id: 1
2021-03-24T14:52:13.911Z zigbee-herdsman:deconz:driver Port closed
2021-03-24T14:52:13.922Z zigbee-herdsman:deconz:driver Timeout for request - CMD: 0xa seqNr: 1
Zigbee2MQTT:error 2021-03-24 15:52:13: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2021-03-24 15:52:13: Failed to start zigbee
Zigbee2MQTT:error 2021-03-24 15:52:13: Exiting...
Zigbee2MQTT:error 2021-03-24 15:52:13: undefined

is this of help??

Hi, can you post your full Zigbee2MQTT config please? Thanks.

I’ve got it working by reinstalling the USB drivers on my Synology ! Ash works like a charm now