Zigbee2mqtt with ZHA?

I was struggling with trying to get the deCONZ Add-on working with the ZHA integration on my Rpi4 with HassOS, only to find out that they can’t both be on the same device (they could, but it brought my existing ZHA network to its knees).

So now I’m wondering if the Zigbee2mqtt Add-on will work alongside ZHA on the same Pi. I’ve got the official Mosquito MQTT broker installed and working, and the Zigbee2mqtt installs, but it fails to start. Error messages below, Is this also a case where in order to use Zigbee2mqtt I’d need to first remove the ZHA integration?

Zigbee2MQTT:error 2020-12-07 22:31:38: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2020-12-07 22:31:38: Failed to start zigbee
Zigbee2MQTT:error 2020-12-07 22:31:38: Exiting…
Zigbee2MQTT:error 2020-12-07 22:31:38: Error: Error while opening serialport ‘Error: Error: Resource busy, cannot open /dev/ttyACM0’

I’m not running on a Pi (I am on a NUC) and I don’t use the add-on version of zigbee2mqtt but I do use the docker container so it is functionally equivalent and I also run ZHA on the same machine and I have no issues at all with them both running.

1 Like

Does anyone else have any feedback on this? I am running HASSIO on RPI4. Currently running ZHA with Sonoff devices. No problems except the motion sensor issue of 1 minute. Apparantly, on the ZB stack, there are messages (lower level) that you can access to circumvent the problem. Want to keet ZHA but run ZB2MQTT at same time…

1 Like

I should have clarified the above…

you can’t run ZHA & Z2M at the same time and both using the same zigbee controller.

I have two zigbee controllers so it works like that for me.


Thanks, understood…

İf i have two controller ( ZH + Z2M) if i connected both device in the same time, can i use together? I’ve sonoff wifi zigbe bridge with tasmota, if i connected an usb dongle, there is can be an issue?

I hope I’m not misunderstanding but I think you should be fine in that case.

I ran two different controllers - one using ZHA and the other using Zigbee2mqtt - for a while and both worked fine together.

It shouldn’t matter what the controllers are as long as they aren’t accessed using two different integrations.


Thanks for the information. So i can use 1 HA host with two zigbee platform (ZHA+Z2M)

yes that’s correct

1 Like

Thanks for the information dude

1 Like

To clearify; can run 1 HA host with two zigbee platforms but will need 2 Zigbee Coordinator adapters.

I’m having a lot of trouble running Zigbee2mqtt and ZHA at the same time using two controllers, could you let me know the steps you took to set your server up?

zigbee2mqtt mentions you can’t run it if ZHA is active at the same time FYI, but I believe you and wonder what you did to pull it off.

The only limitation I know of that would prevent running both zigbee2mqtt along with ZHA is if they are trying to access the same zigbee controller. If you have two controllers and ZHA accesses one and zigbee2mqtt accesses the other then there should be no issues. ZHA and zigbee2mqtt shouldn’t even know that the other exists.

It’s been a long time since I’ve used both together (I only use ZHA now) so I don’t know how much help I can be if there is anything new that might prevent it working together.

What specific troubles are you seeing?

1 Like

I’m running zha and Zigbee2MQTT simultaneously. I’ve done this using different combinations of USB sticks.

Example A:
ZHA with Nortek HUSBZB-1
The HUSBZB-1 is detected as two devices: /dev/ttyUSB0 (zwave) and /dev/ttyUSB1 (zigbee). ZHA is configured to use /dev/ttyUSB1.

Zigbee2MQTT with ConBee II
The ConBee II is detected as /dev/ttyACM0. My Zigbee2MQTT serial configuration is:

port: /dev/ttyACM0
adapter: deconz

Example B:
ZHA with Nortek HUSBZB-1
The HUSBZB-1 is detected as two devices: /dev/ttyUSB1 (zwave) and /dev/ttyUSB2 (zigbee). ZHA is configured to use /dev/ttyUSB2.

Zigbee2MQTT with SONOFF Zigbee 3.0 USB Dongle
The SONOFF is detected as /dev/ttyUSB0. My Zigbee2MQTT serial configuration is:

port: /dev/ttyUSB0

I’m running Home Assistant OS, so this is how I currently find all my USB devices on the system:

  • Settings->System-> Hardware
  • Click the three dots in the top right corner
  • All Hardware

Home Assistant 2022.10.5
Supervisor 2022.10.0
Operating System 9.2
Frontend 20221010.0 - latest
Zigbee2MQTT Add-on - 1.28.0-1