Zigbee2MQTT Xiaomi body sensor only displaying occupancy, not battery

I am using WiFi/Bluetooth for all of my devices but I want to transition to Zigbee. I ordered a starting kit of CC2531 from AliExpress and flashed the Zigbee2MQTT using the explanation on https://www.zigbee2mqtt.io/.

I have a Xiaomi Mijia body sensor (which is supported: Xiaomi RTCGQ01LM control via MQTT | zigbee2mqtt.io) that I was able to connect using Zigbee by simply resetting it and having my MQTT broker up and running. It connected automatically and I can see the following messages being sent:

Aug 30 13:37:53 raspberrypi npm[5642]: Zigbee2MQTT:info 2021-08-30 13:37:53: MQTT publish: topic 'zigbee2mqtt/0x00158d0004a9770e', payload '{"battery":100,"linkquality":86,"occupancy":true,"voltage":3045}'

I’ve set up MQTT discovery in my Home Assistant as well using the details here: Home Assistant | zigbee2mqtt.io and my Xiaomi body sensor was added automatically to Home Assistant. However, for some reason I can only have the “occupancy” entity and not the “battery”, “linkquality” and “voltage” entities, which it is exposing as well (see above). Any idea how I can still access these entities?

Look at the device (configuration → devices). I recently found out Zigbee2Mqtt discovery can detect entities, but leave them disabled. Enabling them makes them visible.

@francisp I’ve taken a look but I can still only see the “occupancy” entity in here:

Though in the received messages I can see the other data. It’s just not showing up as an entity.

What version of HA are you running ?

@francisp hope this helps

That is why they are not showing.


@francisp Thanks, that did indeed solve it!

I have the same problem.
So what is the end? Are you manage to show that battery entity? How to do that?