ZigbeeMQTT error


Yes, there is nothing on there regarding this error

Already read through that but there doesn’t appear to be anything that corresponds to what I am trying to do. Someone makes reference to making a change but not what that change was. Someone mentions editing some code they put in but I didn’t enter any code

Paste the contents of zigbee2mqtt/configuration.yaml.

homeassistant: true

That’s it

Then that’s why it does not start.

I wonder why that would be the case that mine has nothing in it? I need to take a look through that, thanks

What I take from that is I paste the below in the .yaml?

permit_join: true
  server: mqtt://localhost:1883
  # Could be either USB port (/dev/ttyUSB0), network Zigbee adapters (tcp:// or mDNS adapter (mdns://my-adapter).
  port: /dev/ttyUSB0
# Will run frontend on port 8080
frontend: true 

Correct, that is the minimal working config. You need to modify it to suit your installation. I can help if you share details.

Thank you.

What details would I need to share?

To get it running you at least need your coordinator (USB-stick) configured correctly. How you are running this (HAOS? Docker?) what hardware you are using (coordinator) etc. I assume you’ve followed this guide if running it as an addon? GitHub - zigbee2mqtt/hassio-zigbee2mqtt: Official Zigbee2MQTT Home Assistant add-on

I have the Home Assistant yellow which has Zigbee built in and as far as I am aware, all other necessary bits of hardware. I also have MosquitoMQTT which I thought might be causing an issue but apparently I need both.

All I am trying to do is what I have posted here

Ah, I see your problem. You are running both ZHA and Z2M. You can only run one of them.

Aha so I would need to stop the integrated Zigbee integration? Or could I get this switch to work via that?

If you want to run Z2M you need to stop ZHA, yes. I’m not familiar with the brand or the switch, but this is listed as supported in both Z2M and ZHA and seems very similar. Candeo Modmote Scene Switch CMM-1 Zigbee compatibility

That’s the exact one I have. It is integrated into ZHA but it doesn’t actually work. there are 4 buttons, each with 3 functions, so 12 functions in total.

when I look at the entity there is no mention of buttons as you can see here but when I create an automation, there are options for button 1 press, buttons 1 press and hold etc but they do not actually work.

I’m not familiar with ZHA since I run Z2M myself. You could try Z2M and see if that exposes all functions. If not it might not be supported out of the box and you’ll need to add a custom converter (in Z2M).

I see from this thread from november 22 that it was not supported at the time, but there’s instructions on how to manually add it. How to get my Zigbee2MQTT device working (TS004F)

I also see that your device only reports 5% battery, might be worth a try to change it.

There is no entity associated with that sort of device. It generates events, and you automate based on that.

In the screen in your pic, click + next to automations and you should see options. Proceed from there.

I have the same problem
any news on this front ?

[17:43:26] INFO: Preparing to start...
[17:43:26] INFO: Socat not enabled
[17:43:28] INFO: Starting Zigbee2MQTT...
Zigbee2MQTT:info  2024-02-29 17:43:34: Logging to console and directory: '/config/zigbee2mqtt/log/2024-02-29.17-43-34' filename: log.txt
Zigbee2MQTT:info  2024-02-29 17:43:34: Starting Zigbee2MQTT version 1.35.3 (commit #unknown)
Zigbee2MQTT:info  2024-02-29 17:43:34: Starting zigbee-herdsman (0.33.8)
Zigbee2MQTT:error 2024-02-29 17:43:34: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2024-02-29 17:43:34: Failed to start zigbee
Zigbee2MQTT:error 2024-02-29 17:43:34: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
Zigbee2MQTT:error 2024-02-29 17:43:34: Exiting...
Zigbee2MQTT:error 2024-02-29 17:43:34: Error: spawn udevadm ENOENT
    at Process.ChildProcess._handle.onexit (node:internal/child_process:284:19)
    at onErrorNT (node:internal/child_process:477:16)
    at processTicksAndRejections (node:internal/process/task_queues:82:21)


enabled: false
master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
options: “-d -d”
log: true
permit_join: true
server: mqtt://localhost:1883
port: /dev/ttyACM0
adapter: ezsp
frontend: true

the zha worked ok, i delete the zha configuration and install mqtt2zigbee.

This was solved. Read the thread.