Zoneminder 1.32.1, HA 0.79.3 - Broken?


#1

Hey All:

Did a dumb, as usual. Upgraded both HA 0.78 to 0.79.3 AND Zoneminder 1.30.4 to 1.32.1. You know, the nicest possible way to set yourself up to look for bugs. Rebooted Zoneminder server, waited for it to come back up (pretty new interface that works even worse than the old one, if that was possible), then rebooted HA server. HA now doesn’t even think ZM exists.

JSON decode exception kicks off the various “cannot connect” messages. I’m not on a system that will let me copy the log, so I hope this indicates the issue:

Warning: Use of undefined constant ZM_OPT_USE_API - assumed ZM_OPT_USE_API (this will throw an Error in a future version of PHP).

Any thoughts?

–Databoy2k

–edit-- Confirmed that my APIs are borked; if anyone here knows what might have borked them, please let me know. http://[ip]/zm/api returns the following:

Warning (2): Use of undefined constant ZM_OPT_USE_API - assumed 'ZM_OPT_USE_API' (this will throw an Error in a future version of PHP) [APP/Controller/AppController.php, line 63]
Warning (2): ini_set() [<a href='http://php.net/function.ini-set'>function.ini-set</a>]: Headers already sent. You cannot change the session module's ini settings at this time [CORE/Cake/Model/Datasource/CakeSession.php, line 581]
CakePHP: the rapid development php framework
Warning (2): ini_set() [<a href='http://php.net/function.ini-set'>function.ini-set</a>]: Headers already sent. You cannot change the session module's ini settings at this time [CORE/Cake/Model/Datasource/CakeSession.php, line 581]
Fatal error: Uncaught FatalErrorException: [CakeSessionException] Unable to configure the session, setting session.use_trans_sid failed. #0 /usr/share/zoneminder/www/api/lib/Cake/Model/Datasource/CakeSession.php(732): CakeSession::_configureSession() #1 /usr/share/zoneminder/www/api/lib/Cake/Model/Datasource/CakeSession.php(219): CakeSession::_startSession() #2 /usr/share/zoneminder/www/api/lib/Cake/Model/Datasource/CakeSession.php(248): CakeSession::start() #3 /usr/share/zoneminder/www/api/lib/Cake/View/Helper/SessionHelper.php(134): CakeSession::check('Message.flash') #4 /usr/share/zoneminder/www/api/app/View/Layouts/error.ctp(46): SessionHelper->flash() #5 /usr/share/zoneminder/www/api/lib/Cake/View/View.php(971): include('/usr/share/zone...') #6 /usr/share/zoneminder/www/api/lib/Cake/View/View.php(933): View->_evaluate('/usr/share/zone...', Array) #7 /usr/share/zoneminder/www/api/lib/Cake/View/View.php(546): View->_render('/usr/share/zone...') #8 /usr/share/zoneminder/www/api/lib/Cake/View/View.php(481): View->renderL in /usr/share/zoneminder/www/api/lib/Cake/Error/ErrorHandler.php on line 138

#2

Any solution to this? I’m just starting out with zoneminder, but having all sorts of problems getting it to integrate nicely with HA.


#3

This problem was actually a broken system on my end. Spend your time working on making sure that you can access your APIs on Zoneminder.