Zooz ZEN25 firmware update bricked plug?

I got a notification from Home Assistant today that my Zooz ZEN25 Double Plug had a firmware update. I went ahead and installed it. It appears the update bricked the Smart Plug. It is not responding to Zwave or manual interactions. Power cycling did not do anything to recover it. I tried the factory reset procedure (press and hold button for 10+ seconds) and while it did change the colors of the lights during that process at some point, it doesn’t seem to have recovered it. It behaves exactly like it did before attempting the reset.

Anyone else experiencing this? Anyone else having had success with the firmware update on the ZEN25? Any recommendations on how to revive the plug?

1 Like

After having messed around with the plug a little more, it seems like it is actually working for the most part (i.e. it actually responds to Zwave commands and I can turn on and off the LED indicators by pressing the button 6 times). However, switching the actual outlets doesn’t actually work. Maybe the relays failed. Not sure how a firmware update would cause that and on both relays nevertheless, but that is the best explanation I have right now. :-/

I’m having the same issue after the update. I found this on the Zooz site:
“If your device doesn’t function correctly after the update is complete, please exclude it from your hub, factory reset the device, and then re-include it.” How to Perform an OTA Firmware Update on Zooz Devices - Zooz Support Center

I haven’t tried yet but if not working by morning I will.

I checked settings and saw unexpected values for the plug. It disabled local control and set tripping limit to 0. Re-enabling local control and resetting to 10A limit seems to bring it working.
However, day later, it just died. Node appears dead. I will investigate later

I excluded and then readded. Did not work until I unplugged and then plugged back in.
I’ll check again tomorrow to see if still working.

I think I made some progress. Thanks to @Tomek985 for pointing out that local control was disabled on his plug, this got me on the right track.

The update seems to have messed up the configuration big time. There were three major problems that had to be fixed in my configuration to make the plug work again:

  1. Disable auto on and auto off timers. It appears the update activated all the time-based auto on and auto off timers.

  2. Re-enable local control. It appears the update disabled local control

  3. Reset overload protection to 10A (Default). The update seems to have set the overload protection to 0A, causing it to immediately go into overload protection panic. Note that I had to power cycle the switch after changing the configuration value. Just resetting it from HA was not enough.

Right now it seems to be working normally again. Let’s see if that remains.

1 Like

Mine works for a few hours and then goes dead/disappears.
I checked all those settings but none needed changing.

Mine stayed non-responsive twice and reconnected after re-plugging.
What I found peculiar is that Over-load detected is always “UNSAFE”
Not sure if that was always the case or just with FW update

Mine was showing unsafe, too, but I was able to fix it by setting the overload protection Z-Wave setting back to 10A, physically replugging the outlet and finally using the Idle Power Management Overload Status Reset button in Home Assistant.

Skipping either one of the two first steps would just lead to it flipping back into unsafe immediately.

2 days ago I excluded, unplugged/replugged, readded, unplugged/replugged, and it has been stable so far.

Device may not technically be bricked, but functionally for the average user the device stops working after the upgrade. At least recommend it not be pushed through the HA updater since there are known issues with it.

I swapped my most important one out for another device after the upgrade broke it. I’m sure I can get that working eventually but haven’t had time to mess with it yet.

Same here. It controls a lamp in the living room that is not used that often. It died a few days ago, most likely after the firmware update.

Will have to reset and readopt tomorrow and see how it goes.

Module is dead again. Excluded, factory reset, included again. Checked the settings and all defaults appear correct. The plug responds to on/off commands, but not reliably - I normally use the main switch that controls both plugs, but it seems it sometimes only switches one of the plugs - randomly.

After switching the plugs on/off a few times, it hangs and the module is dead. Re-plugging the module in recovers it. Its running FW: v2.10 SDK: v6.71.3

I would try looking at the logs files. If you search for dead it will tell you why the device was marked as dead.

thanks. I will take a closer look.

After disabling the power monitoring setting ( I dont use it for this specific module), it has been behaving and not going dead, at least for the last 24 hours .

After device “bricks” itself, it won’t even respond to button presses. I was hoping even if it is just Z-wave only problem, the relay should still work, but it doesn’t. It requires power cycle to be operational.

I excluded it, factory reset, include and still cannot get 24h of availability.

Another thing I may try is to use unsecured connection as change log hints that:

Firmware: 2.10 (released 4/2023 as OTA)

  • Addressed issues with reporting when outlets are triggered via physical button when Double Switch is added with S2U security on select platforms.
  • Addressed issues with secure inclusion that affected the metering reports on select platforms.
1 Like

Okay, Zooz Support is insisting that I try excluding and re-adding without security…
Now, that being said, I have another Zen25 that did lockup, and require factory reseting after the firmware update… But since then hasn’t locked up, and it also has no security.

All the models with S2 enabled, have locked up within 1-3 days… Well excluding the kitchen lights, but I know they locked up at least once…

They are also starting to try to push this onto Homeassistant, saying it’s a HA issue, please get support from them… I’m pushing back…

I also submitted ticket and I was personally suspecting either S2U problem or metering since they are explicitly mentioned in the changelog. So far they haven’t pushed back but already asked for settings and connection type, so I expect them to ask to connect without security.
I will try to disable metering and see if it helps as well.

I had this same problem, and factory reset + add without security seems to have fixed the problem for me.

Has anyone tried legacy security to see if that works any differently? Something is probably better than nothing.

I disabled metering reporting and can confirm that plug is stable for few days already.
I am using S2U