Zooz ZSE18 not acting as Z-Wave repeaters

I have two of these motion sensors powered by microUSB, not battery. They work fine, except for one thing : they aren’t properly acting as repeaters. I had to purchase an additional smartplug (I got a Minoston model, not Zooz) to get my Z-Wave range issues resolved.

Zooz tech support gave me multiple suggestions, such as healing the Z-Wave network, and removing/adding back the motion sensors to the network, none of which worked.

Is anyone else seeing the same problem with this device ?

Is there a workaround or solution to force the repeater to work ?

In the Z-Wave ecosystem there are (3) roles types Reporting Sleeping Slaves, Listening Sleeping Slaves, and Always On Slaves. Always On Slaves are the only devices that can act as a repeaters. According to the information I found on the Z-Wave Alliance Product Page, the ZSE18 is a reporting sleeping slave. This means it cannot act as a repeater despite it being being powered. My Ring Keypad V2 works the exact same way. I will do more testing later but I don’t think its ever worked as a repeater even when wall powered. I think by mains powered they mean 120/240V.

Seems like it’s just plain old false advertising from Zooz then, since they claim the ZSE18 will act as a repeater when powered.

Was the device mains-powered when you originally included it? That step is necessary to include as an always-on device. If you include on battery power it will be a sleeping device, even when plugged in later. Also: Add Your ZSE18 Motion Sensor as Signal Repeater on USB Power - Zooz Support Center

How are you determining whether the device is acting as a repeater or not?

Yes, it was mains-powered when originally included.

I am determining it’s not acting as a repeater by the lack of range, and the fact that adding other devices (smartplugs) advertised as repeaters in the same location is effective at increasing the range.
I believe there was also some info in HA itself that indicated the device wasn’t acting as repeater. I don’t recall where that is.

You can download the device diagnostic file and look for the isListening property. If the value is true, it means the device claims it supports repeating. If false, it doesn’t repeat.

isListening is false.

Well, that seems like a problem. Non-listening devices are excluded by controllers for routing purposes. I would try excluding and re-including the device again, ensuring it’s on mains-power. I would also remove the battery if it’s inserted. If you repeat this and the listening property is still false, then I would take that back to Zooz support, if this is still a problem for you.

Thanks. I removed the battery, ran exclusion, and then inclusion again. The isListening property is still false. isRouting is true, for some reason.

I guess you’d need to ask Zooz and confirm if that is the expected behavior. My understanding is that if the device reports it’s not listening, it won’t be used as a repeater. So even though it’s always powered, the controller doesn’t know that.

I think you’ll find that isRouting is true for every end device in your network. I think that just means the device has routing capabilities, e.g. it knows how to route messages to other nodes like the controller.

Thanks. I have forwarded this thread to Zooz support once again. Let’s see what they say.