ZW062B Aeotec Garage Door Opener not available in Home Assistant

Hey all, hope somebody can help me out please.

I have a Aeotec ZW062B Garage Door Opener that is connected to HA via a Vera Plus, this was detected and working well a month or so ago but has now disappeared from home assistant! All other Vera devices (lights, switches Etc) are still available and working and all of the scenes that relate to the garage door are also listed under “customization” but the door opener itself is not listed! If I browse to Vera then the garage door is available and works OK, just not available in HA.

I have tried removing the garage door opener from Vera and rebooted both Vera and HA, re-added the opener and again re-booted both Vera and HA, but again the Garage Door is not available in HA.

I’m hoping this is relating to one of the recent updates but not sure which one!

Thanks in advance for any help you guys can offer!


Do you know which version of HA you had when it was working, and which one you are on when it stopped?

Hi alanf, thanks for your quick reply.

Unfortunately not, I hadn’t used the garage door for a couple of months so didn’t notice when it disappeared. It is strange that it is still available and working in Vera and all devices and scenes should automatically be available in HA which most are, just not the Garage door. The only thought i had as to why only the garage door opener is affected is the Luup device category may for some reason not be recognized now (currently set to category 32 and sub-category 0) although I have tried changing the category to a normal switch, rebooted Vera and HA but still no Garage Door! :frowning: I am right in thinking that HA should automatically add new devices when they are connected with Vera, I shouldn’t have to manually re-scan in some way??

Thanks again for your help!

Just as a test I have managed to create a scene in Vera to open the garage door manually and that scene is available in HA and works to open the garage door! That scene also works from Google Home (via HA) and again works correctly, it’s just frustrating that I currently have to Start or Activate a scene in order to operate a switch/Garage Door Opener.

Thanks again for any help you can offer!

Another update, I have tried restoring from a snapshot including Home Assistant Ver 0.73.1 which i’m sure was around the time that the Garage door opener was working so my theory that this may have been caused by an update is not looking so likely!

There have also been a couple of Vera updates recently so I guess one of those may have caused the problem but i’m at a loss of what else i can do to get it working again now!

It looks like type 32 isn’t supported in pyvera, which HA uses for vera support. I could look at adding support there, but for now I’d suggest you try type 8 or 3, those should be curtain or a switch. Both are supported by pyvera.

Fantastic! Thank you!

I had tried changing the type to another type previously and it still wasn’t available but setting it to 8 worked a treat! If type 32 is supported in the future then I will switch back but for the time being i’m all good! :slight_smile:

Thanks again!

Sorry, another minor issue! each time Vera is rebooted the Garage Door Opener defaults to Luup Catagory 32! I have tried saving the category type a few different ways and gone back into advanced and showing Category 8 but as soon as it is rebooted then it changes back to 32! At least i now know what the issue is thanks to your help and I can work around it to get it working!
Thanks again! really appreciated!

I am having a similar problem. I have a garage door opener connected to a Vera Plus and it is being imported into HA as a switch. When you say change the category to 8 are you referring to the category_num property listed in the Vera controller page under Advanced/Params? If so do you also need to change the subcategory_num property as well? Mine are currently set as category_num 3 and subcategory_num 5.

Hi, Had a similar problem when I upgraded my Vera controller recently. I don’t have the Aeotec Garage opener, but another brand, and it’s re-classified the category to 32 in Vera too.

Reading around on the issue, looks like the verison of pyvera in the current docker container I use for HASS is outdated. Pyvera itself was updated about 16 days ago to support the new category in Vera.

to fix this until pyvera is updated in the docker image, pull the pyvera master from (or download the files if you like) into your HASS site-packages directory (mine is /usr/local/lib/python3.6/site-packages/pyvera)

The two files are (underscore underscore)init(underscore underscore).py and

Once I did this and restated HASS, it picks up my garage opener using the category number 32.

It looks like the updated pyvera has been merged in dev with this PR: Hopefully that means this will be in the next release.

Yay, Thanks guys! :slight_smile: