Zwave Add Node Secure + HassIO

Tags: #<Tag:0x00007f3264dbbd50> #<Tag:0x00007f3264dbba80>

Hello,

Has anybody had luck with Add Node Secure and HassIO? I’m trying to pair a Schlage Connect lock with no success. I’ve tried a bunch of things including the prefered process shown below to no avail.

  1. Leave Aeotec Zstick in the Pi
  2. Hit Remove Node button in Hass UI
  3. Put lock into add/remove mode (Schlage button -> programming code -> 0 ), wait for green check
  4. Factory reset the lock (unplug battery, hold schlage exterior button, reconnect batteries)
  5. Restart HA
  6. Hit Add Node Secure in HA UI
  7. Put lock into add/remove mode (Schlage button -> programming code -> 0 ), then it throws a red X within 10 seconds

My leading theory is the network key I set in the HA config isn’t being set correctly in OZW. Can anybody confirm it is working correctly or point me to the prefered way to check? \

HA Config shown below.

configuration.yaml

zwave:
  usb_path: /dev/ttyACM0
  network_key: !secret zwave_network_key
  new_entity_ids: true

secrets.yaml
zwave_network_key:  "0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01"

Cheers!

Hello!

I am brand new to HA. I successfully setup my RPI3 and pulled in all my Wink attributes into the HA system. I wanted to migrate my Schlage Connect locks directly into the HA system via my z-wave stick. I tried all weekend but was unable to get it to pair via the “Add Node Secure” process. I have been going all over the forums trying the different tricks such as moving the RPI3 + stick closer to the lock, removing then adding the lock, resetting the lock etc… in the specific processes that some users have gone through, including the one that you outlined in your post.

For some reason i was unable to get it to pair. I ended up adding the lock back to the Wink 2 hub and it paired flawlessly.

I will try again but figured that I need to do some more research or wait until i uncover a process that works for me.

I will be following so hopefully we’re able to uncover an easier way of getting this to work. Based on the posts that i’ve seen these locks are pretty difficult to pair in HA.

I used your config and the add node secure from the developer page, the only information I changed was for the network key, where I removed all of the spaces inside of the string. This was tested on a Yardi YRD220 and confirmed it to properly unlock/lock.

1 Like

Thanks much. Just to confirm, you’re running HassIO and the lock paired using the Add Node Secure function? I think it may default to Add Node if the Add Node Secure function fails. The Schlage Connect can’t pair insecurely (I think), not sure about the Yardi. Cheers!

Not sure if it helps, but I had it paired before I moved to HassIO, and it still works now. That being said, before I got it working originally I had to reset the lock and the Z-Stick a few times, then it started to behave. Again, that was all before HassIO, but it does still work now.

Interesting. Yeah, very flummoxed. I have tried absolutely every combination of resets I can think of. Can you share how you have your network key setup? Formatting, commas, all that. Thanks much!

zwave:
  usb_path: /dev/ttyACM0
  network_key: !secret zwave_network_key
  new_entity_ids: true

secrets.yaml
zwave_network_key:  "0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01"

I got something like this and its working…

In my case, I think that my network key was not set. I was able to set it up last night and everything now looks good. I did not have an opportunity to try and pair my lock but I will give it another go this weekend.

I have my configuration in a “zwave.yaml” file in a subdirectory called “packages”. Done it this way both before and after. I seem to recall I had issues when there were spaces inside the quoted key and manually removed this a while back to get it working.

Good luck!

configuration.yaml

homeassistant:
  name: Home
  latitude: 00.0000000
  longitude: -00.0000000
  elevation: 000
  unit_system: metric
  time_zone: America/Toronto
  packages: !include_dir_named packages

zwave.yaml

zwave:

  usb_path: /dev/ttyACM0
  network_key: "0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00"

Thanks much for the feedback! After a few more hours of playing around I finally gave up and factory reset my entire Zwave network. Unpaired all my devices, factory reset the Zstick, and the lock. With the network key set, the lock paired on the first try using the add node secure button in the HA UI.

I added the rest of my devices using the HA UI (rather than via the Zstick button) and haven’t had any issues.

I’m wondering if my issue stems from adding some devices using the Zstick directly and some from the HA UI.

Anyway, now that everything is paired via the UI it’s running great. Thanks much for all the help!

Update: I too was able to succeed and connect my lock. I had to take the spaces out of my network key and that did it! I was able to pair the lock in a matter of seconds on the 1st attempt. A big thanks to everyone on these boards!!!

I’m a hass.io and zwave newbie, but I was able to connect my Schlage BE469NXCEN using these instructions (I did remove the spaces in my network key). Yes, I used Add Node Secure. However, it does not actually allow me to control the lock. All attempts to send the lock command result in
“ERROR: Dropping command, expected response not received after 1 attempt(s)” in the log, and nothing happening to the lock.

I saw other posts where this appears to be due to a network key mismatch, and people were resolving it by editing an options.xml file for openzwave. But, using hass.io, I don’t think I even HAVE that. Or if I do, I do not know how to access it.

Were the posters here able to actually control their locks, or just pair them?
How could I tell if my network key is actually getting used?
What else could possibly cause this error?

I was able to get my lock up and running following these same steps… Factory reset my Z Stick, unpaired my lock, removed the spaces from the network key, and added the lock via the add secure node button. To me, the issue seemed to be the fact that some of the devices were added via the Z Stick rather than the UI.

BTW, thanks for all of your great YouTube videos! Wouldn’t be using HA without them.

where fine a network key for zwave stick ?

You need to generate one and then save it in your config file. There’s a script you can run to generate one. See here https://home-assistant.io/docs/z-wave/adding/#adding-secure-devices