Zwave and Modemmanager

Hey guys. New to the HA world and drinking from the fire hose to get everything started. Running a rpi3 and hassio. I purchased a zwave usb stick and was reading through the documentation for install and they have a blip in there about disabling or uninstalling Modemmanager service. Im a bit confused about how and even where i need to do this? is this something home assistant runs or is it deeper on the back end of the pi? Thanks in advance on how to do this!

This is just for Ubuntu I think.

maybe they have this in the documentaion in the wrong section?

Platform specific instructions

You do not need to install any software to use Z-Wave.

If the path of /dev/ttyACM0 doesn’t work, look in the System section of the menu. There you’ll find a Hardware button which will list all the hardware found.

You can also check what hardware has been found using the hassio command:

$ hassio hardware info


The modemmanager package will interfere with any Z-Wave (or Zigbee) stick and should be removed or disabled. Failure to do so will result in random failures of those components. For example you can disable with sudo systemctl disable ModemManager and remove with sudo apt-get purge modemmanager

look at the last sentence of the last thing you posted above. It tells you how to do it there:

Where you do that is thru the command line on your HA linux machine using SSH.

ok cool i will give that a shot. sorry for the beginner question. trying to learn as i go

thanks again for the help

Yeah, no problem. We were all beginners at one time.

i installed ssh addon for hassio
configured to auth key and i am connected to root in putty

i try to run the command above and i just get command not found. Did i do something wrong? im sure its something very simple i am just not understanding?

You are SSHing into the HA container with that add-on. You need to connect to the host OS either using SSH to the IP address of the Ubuntu box or by typing the commands from the device itself.
This greatly improved the reliability of my zwave environment.

I completely missed that you are on hassio.

I’m not sure that the issue applies to hassio (as sergi referenced above…)

As far as I know, it only applies to the Intel NUC. For sure, no need to worry about modemmanager on a RPI.

I think it depends on the host OS. If your host OS contains modem manager, you should disable or remove it. I believe HassOS doesn’t contain it. Ubuntu does. Other OSes might or might not.

If you are running a default Hassio install with HassOS on your Pi, I don’t believe modem manager is an issue. Then again, I might be mistaken.

Thank you all for the help! I guess i was just reading that part as part of the hasio install

thanks all again!