ZWave and Wifi switches in a group

Hi, just starting out with Home Assistant.

I have a Wemo (wifi) light switch and a ZWave light switch. I would like to put them in a group, so I can turn them on/off with as a group entity.

I’m not sure if I should use:






Or how do I tell what type of service an object falls under? Maybe I need to make 2 calls? 2 groups?

Thanks for your help…

As far as I know you can use either one, but I am not sure if it’s possible to set some data like rgb values with homeassistant.turn_on, but you can always test and see for yourself using the developer tools - services page. It’s in the left sidebar and looks like a remote control.

In the service data (json) you just write the unit like this: {"entity_id":"light.one_device_etc"}
The states page <> is good to find the names of your units.

I would add them up to the same group and try with homeassistant.turn_on + {"entity_id":"group.the_new_group"} and see what happens.

Thanks for your reply.

I tried homeassistant.turn_on

but only the Wemo gets turned on, and I see the following error:

[homeassistant.core] Unable to find service zwave/turn_on

The Wemo turns on but not the zwave

then I tried light.turn_on

Neither gets turned on

then I tried switch.turn_on

and just the Wemo gets turned on

Any other ideas?

homeassistant.turn_on should work and automatically call the correct service for the component. Can you post the config for the group as well as the automation you’re testing with?


- alias: Turn on outdoor lights at sunset
    initial_state: True
    hide_entity: False
      platform: sun
      event: sunset
#      - service: homeassistant.turn_on
#        entity_id: group.outdoor_lights
#      - service: light.turn_on
#        entity_id: group.outdoor_lights
      - service: switch.turn_on
        entity_id: group.outdoor_lights


    - switch.front_eave_pots
    - zwave.intermatic_ca3000_wall_switch_4

Ah, so you have the wrong entity for your zwave switch in that group. The zwave entity itself is really only useful for seeing if it’s awake/asleep/etc. You need to find the associated switch or light entity.

If you look at the list of states in HASS, you should see something along the lines of switch.intermatic_ca3000_wall_switch_switch_4_0 in that list. Use that in your groups.yaml file rather than the current one you have. Then the homeassistant.turn_on service will correctly turn them both on.

That seems to have solved it for me. Thanks.

Onto my Schlage deadbolt…