Zwave Battery Sensor Unavailable / Network Not Starting

Out of no where, I am getting my zwave battery nodes going unavailable . There was no change to the network, I didn’t add or remove any nodes, there was no improper shutdown of my server or hass. I have tried to delete the zwcfg_ file, but it isn’t getting recreated. I have replaced it with a back up of the zwcfg_ file (which was previously working) but still getting `unavailable. I have restarted hass and the machine itself. Upon restart, I have to manually start the Z-wave network (it isn’t starting automatically). I am on 116.4 in docker.Has anyone seen this or know a fix?

Have you tried waking the devices? Most of the battery devices I have seen have long wakeup periods… I’ve found that by pressing the Zwave/wakeup button on the devices, they come alive again.

Zwave not starting automatically seems concerning though.

Yep, I haven’t tried it on every device, but on a small sample size. No results

I’d try kicking up the logger level (debug) and seeing if any errors are being thrown as HA (and the Zwave network) is starting up. Perhaps there is a node that is causing the Zwave network instability (I had a switch become faulty and mess up my entire network a while back).

Here is the only thing I get in the log:

Logger: homeassistant.components.zwave
Source: components/zwave/
Integration: Z-Wave (documentation, issues)
First occurred: 2:46:14 PM (17 occurrences)
Last logged: 2:46:14 PM
Z-Wave node 58 not ready after 30 seconds, continuing anyway
Z-Wave node 66 not ready after 30 seconds, continuing anyway
Z-Wave node 67 not ready after 30 seconds, continuing anyway
Z-Wave node 85 not ready after 30 seconds, continuing anyway
Z-Wave node 86 not ready after 30 seconds, continuing anyway

Here is some info from the Zwave Log for one of the above node:

B2020-11-23 15:02:46.529 Detail, Node058, Received: 0x01, 0x07, 0x00, 0x13, 0x5d, 0x01, 0x01, 0x9c, 0x2a
2020-11-23 15:02:46.529 Detail, Node058, ZW_SEND_DATA Request with callback ID 0x5d received (expected 0x5d)
2020-11-23 15:02:46.530 Info, Node058, WARNING: ZW_SEND_DATA failed. No ACK received - device may be asleep.
2020-11-23 15:02:46.530 Warning, Node058, WARNING: Device is not a sleeping node.
2020-11-23 15:02:46.530 Info, Node058, QueryStageRetry stage Probe requested stage Probe max 3 retries 1 pending 1
2020-11-23 15:02:46.530 Detail, Node058, Removing current message
2020-11-23 15:02:46.530 Detail, Node058, Notification: Notification - NoOperation

And what is weird is that at various times overnight, different nodes went to sleep. Some at 1am, 3am, 5am, etc. So it doesn’t seem as though there was something that triggered it, and now all my battery nodes (and one or two powered devices) are unavailable

Not sure what the solution was, but I upgraded to .117.2 and replaced my zwcfg_ with a backup from 6 months ago. The combination of the two brought the network back up.

Ah nice! I’m curious what changed.

No idea, I don’t think it was the upgraded, as I reverted to .116.4 because of a markdown card formatting issue. The only thing I did differently between last night and this morning was adding two zha outlets, but I’m using the sonoff zigbee bridge, so I wouldn’t thing that corrupted any z-wave stuff