Zwave/bluetooth in a docker together?


I managed to get Bluetooth tracker working in a docker, but now zwave stopped working. Any idea how I get them both working please? This is on ubuntu

    container_name: home-assistant
    restart: always
    image: homeassistant/home-assistant
      - "docker-influxdb-grafana"
      - "mysql"
      - /dev/zwave:/dev/zwave
      - /home/mark/HomeAssistant:/config
      - /etc/localtime:/etc/localtime:ro
      - /dev/bus/usb:/dev/bus/usb
      - /var/run/dbus:/var/run/dbus 
    network_mode: host
 #   environment:
  #    - ti
    privileged: true


Is this what the host sees as your zwave USB device?

Hi Mark,
Lucky you, I am still battling trying to get Bluetooh setup correctly on my Ubuntu/Docker setup, so if there is something special that you did could you highlight it or give a few steps?

As far as Z-Wave, this will be my next item to setup. I assume that your “dev/zwave” is a symlink … correct? for me I couldn’t get symlink to work either but I did find that Ubuntu is creating it’s own symlink. For z-wave, you can find it here:
/dev/serial/by-id/usb-0658_0200-if00 --> ../../ttyACM0

This is what I am hoping to use since symlink didn’t work and will put this entry in my configuration.yaml file.
You can find a similar reference in this post:

yeah it is indeed and I can still see that on the host

correct… I have this setup in a file located here

file contents
“SUBSYSTEM==“tty”, ATTRS{idVendor}==“0658”, ATTRS{idProduct}==“0200”, SYMLINK+=“zwave””

EDIT, from this article…

looks like when I add

privileged: true

This kills zwave, but without it BT doesn’t work… any ideas please

I run mine privileged and BT and zwave both work fine.

how frustrating… what OS are you on, I just realised I am on Linux Mint not ubunti

I get this error in HA

2018-11-21 13:59:39 ERROR (MainThread) [homeassistant.config_entries] Error setting up entry Z-Wave (import from configuration.yaml) for zwave
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/openzwave/", line 78, in __init__
    raise ZWaveException(u"Can't find device %s : %s" % (device, traceback.format_exception(*sys.exc_info())))
openzwave.object.ZWaveException: "Zwave Generic Exception : Can't find device /dev/zwave : ['NoneType: None\\n']"

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/src/app/homeassistant/", line 244, in async_setup
    result = await component.async_setup_entry(hass, self)
  File "/usr/src/app/homeassistant/components/zwave/", line 283, in async_setup_entry
  File "/usr/local/lib/python3.6/site-packages/openzwave/", line 81, in __init__
    raise ZWaveException(u"Error when retrieving device %s : %s" % (device, traceback.format_exception(*sys.exc_info())))
openzwave.object.ZWaveException: 'Zwave Generic Exception : Error when retrieving device /dev/zwave : [\'Traceback (most recent call last):\\n\', \'  File "/usr/local/lib/python3.6/site-packages/openzwave/", line 78, in __init__\\n    raise ZWaveException(u"Can\\\'t find device %s : %s" % (device, traceback.format_exception(*sys.exc_info())))\\n\', \'openzwave.object.ZWaveException: "Zwave Generic Exception : Can\\\'t find device /dev/zwave : [\\\'NoneType: None\\\\\\\\n\\\']"\\n\']'

I run my NUC on Alpine Linux

Try using the /dev/serial/by-id suggestion by @berniebl

Weird that so many people try to symlink their device. I have never had it change on my system. It has always been /dev/ttyACM0

1 Like

Oh my… I have always had issues with this it flipping to 0 or 1 and hence why I created a symlink… but as a test I have removed the zwave and put using /dev/ttyACM0 using privileged (true) in the docker compase, so far both zwave and BT are running!

Thank you… I will keep this updated if that changes.

The only time this would flip is if you are unplugging/plugging all the time. Even then, if it changes after plugging it back in, just unplug it and plug it back in, and it will go back to 0

I question those that unplug and plug their zwave controllers all the time…like why?

totally agree… mine is in the loft so I wouldn’t :smiley:
Mine did flip when I was using an RPi3 a reboot could make it flip

I reboot my NUC about once every 3 months. I have never had it flip on me.

good to hear thanks… I only setup the synlink when I moved to the NUC, as that was the way I had it… Thanks for your help!

Let’s hope BT detection works for my presence detection now :smiley: