Zwave broken

I ran the latest upgrades for core etc. and would get the main settings page, but not the devices page nor overview - would not load).

I replaced the microSD with the other one (I rotate two uSD’s for backup) and restored the last backup file (I save backups to a cloud server) and got it running.
I then loaded a new uSD and restored the same backup, but zwave would not come up. I got the below error message in the log.
I ran the latest core update with no change.

I read several threads here that say this is due to having the zwave JS core add-on address, but trying to run the ZUI add-on. But I don’t believe I ever set up ZUI and don’t have a reason to. I don’t think this is the issue.

I disabled the zwave JS addon, and it will not restart when choosing ‘start’ from the add-on page. From the Integrations page, ‘enable’ results in the same error. I restarted HA, no change.

The log from the zwave integration shows normal operation.

Any recommendations are appreciated.

Error: Failed setup, will retry

HA core log:
Logger: homeassistant.components.zwave_js
Source: components/hassio/
integration: Z-Wave (documentation, issues)
First occurred: 2:17:26 PM (8 occurrences)
Last logged: 2:26:19 PM
Failed to start the Z-Wave JS add-on:

from zwave log
2024-05-18T18:47:16.237Z CNTRLR « [Node 022] received wakeup notification
2024-05-18T18:47:16.248Z CNTRLR [Node 022] The node is now awake.
2024-05-18T18:47:16.508Z CNTRLR » [Node 022] Sending node back to sleep…
2024-05-18T18:47:16.575Z CNTRLR [Node 022] The node is now asleep.


  • Core 2024.5.4
  • Supervisor 2024.05.1
  • Operating System 12.3
  • Frontend 20240501.1

I put in the first backup uSD chip and found in the zwave JS config these two entries, where the second uSD showed only the second entry.


I recall having to add in the first entry, but not the details.

I reloaded the second uSD and tried to edit the yaml file to include the first entry. It said it would not save. But zwave seems to be working now. I do not know if this was due to the edit or time (the system might have been finishing its start-up as I was editing).

configuration from integrations page:
older uSD
Driver version: 12.4.4
Server version: 1.34.0
Home ID: 4179798772
Server URL: ws://core-zwave-js:3000

newer uSD
Driver version: 12.5.5
Server version: 1.35.0
Home ID: 4179798772
Server URL: ws://core-zwave-js:3000

I put in the first uSD and restored from a backup from the second uSD that had zwave working.

I now get this in the HA log, and zwave not working.

Logger: homeassistant.components.hassio
Source: components/hassio/
integration: Home Assistant Supervisor (documentation, issues)
First occurred: 8:24:31 PM (2 occurrences)
Last logged: 8:24:59 PM

Failed to to call /addons/core_zwave_js/stats - Container addon_core_zwave_js is not running