ZWave config - LibOpenZwave Exception

I am new in the game and just installed the latest HASS image (0.36.1) on my new Synology DS716+II in a Docker container.

HASS is up and running, atomatically detecting my Hue lights and my Sonos speakers.

But it shows an “Invalid Config” message for zwave.

This is my config:

  usb_path: /dev/ttyACM0
  config_path: /srv/hass/hass_venv/lib/python3.4/site-packages/libopenzwave-0.3.1-py3.4-linux-armv7l.egg/config

the ls command shows a ttyACM0 device - though it might not be the correct one.

But the home-assistent.log shows an exception:
libopenzwave.LibZWaveException: "LibOpenZwave Generic Exception : Can't find config directory /srv/hass/hass_venv/lib/python3.4/site-packages/libopenzwave-0.3.1-py3.4-linux-armv7l.egg/config"

So I assume, that there was change in the image recently and now this config snippet fails. Correct?

I am coming from the .NET / C# / rich client. Therefore this Linux / Bash / Python stuff is totally new for me. But I am eager to learn! :wink:

What happens if you remove the config_path? I run on Synology via Docker, and I omit that line since it’s optional.

Yes! The error in the log is gone now and the “owz_log.txt” tells me, that there is something going on with the zwave stick. Thank you!

Now I just need to learn how to connect and configure all the zwave sensors.

You have to add them in ozwcp (stop homassistant first).

how to do that, when HASS runs in a Docker container?

I’ve never used Open Zwave Control Panel (OZWCP) with Home Assistant. This is not a requirement.

My USB path is also /dev/ttyACM0. For Docker, you need to make sure you have this device mapped to your Docker container. (via --device parameter). Did you do this step? What error is owz_log.txt telling you ?

In the meantime the docker container is successfully mapped to the ZWave stick.

Now having a hard time, to connect/configure the devices (Aeotec Smart Switch 6 and Aoetec Door Controller).
Honestly - I didn’t expect that it is that hard…