Zwave configuration broken following HA upgrade?

Hello :slight_smile:
I’m using :

computer :

  • Z-Wave Plus Aeotec Z-Stick USB Controller (2018)
  • Raspberry Pi 3B+ (2018)

software :

  • Raspbian GNU/Linux 10
  • docker 20.10.18 with homeassistant/home-assistant:latest (2022.9.1)

locks :

  • Yale Smart Lock Z-Wave Module (2nd Generation) (2018)
  • Yale Keyless Connected Lock Kit (2018)

I don’t use HAssio, I use Docker-Compose

version: '3.8'
    image: homeassistant/home-assistant:latest
    container_name: homeassistant
    network_mode: host
      - /usr/share/zoneinfo/Europe/London:/etc/localtime:ro
      - /opt/homeassistant:/config
    privileged: true
    restart: always
      test: "curl --fail --insecure https://localhost:443"
      - /dev/ttyACM0:/dev/ttyACM0

my configuration used to work for 4 years, but now I believe that Home Assistant is managing Z-Wave differently as upgrading Home Assistant broke the config…

Integration error: zwave - Integration 'zwave' not found.

my config :

# for the zwave dongle
  usb_path: /dev/ttyACM0
  # network key is also in options.xml
  network_key: "0x18, 0x0A, 0xB8, 0x9A, 0x96, 0xE0, 0x24, 0xA5, 0xE2, 0x5F, 0xAA, 0x5F, 0x82, 0x39, 0xD7, 0x8F"
# ls -l /dev/ttyACM0
crw-rw---- 1 root dialout 166, 0 Sep 11 18:01 /dev/ttyACM0

and I was using these entities/states for example, which were working well :


How could I get these back to work ? I need the new Z-Wave JS ?

Yes, you must switch to Z-Wave JS (which is now just called Z-Wave) if you want to continue. Notice of this was announced in the release notes:

A migration wizard for legacy Z-Wave to Z-Wave JS was previously added but retired in 2022.4 with the removal of the integration. You can upgrade to 2022.3 first and try the wizard, then upgrade to the latest. However, there was very mixed success with that wizard, and many users had to migrate manually.

There are tutorials in this forum for manually migrating linked from here: Zwave & Home Assistant Overview. As a Docker user you’ll most likely want to use zwavejs2mqtt.

Integration docs: Z-Wave - Home Assistant

1 Like

Thanks for the reply!
I’ll try this in the next few days and update this thread…