ZWave Controller disconnecting

I am new to Home Assistant, coming from OpenHab. I have installed Home Assistant on Ubuntu 20.04 and installed the OpenZWave addon. So far so good.
I plugged in my Homeseer SmartStick+ USB zwave controller (/dev/ttyACM0) and added it to the configuration.

The log shows communication with the nodes, however, after a couple minutes the zwave addon quits with the following log entries:

[20201228 11:43:09.910 CST] [ozw.library] [info]: Info - Node: 0 Stopping DNSThread 
[20201228 11:43:11.912 CST] [ozw.library] [debug]: Detail - Node: 53 Removing current message 
[20201228 11:43:11.912 CST] [ozw.library] [debug]: Debug - Node: 0 Value Deleted 
[20201228 11:43:11.912 CST] [ozw.library] [debug]: Debug - Node: 0 Value Deleted 
[20201228 11:43:11.912 CST] [ozw.library] [debug]: Debug - Node: 0 Value Deleted 
[20201228 11:43:11.912 CST] [ozw.library] [debug]: Debug - Node: 0 Value Deleted 
[20201228 11:43:11.912 CST] [ozw.library] [debug]: Debug - Node: 0 Value Deleted 
[20201228 11:43:11.912 CST] [ozw.library] [debug]: Debug - Node: 0 Value Deleted 
[20201228 11:43:11.913 CST] [ozw.library] [info]: Info - Node: 0 mgr,     Driver for controller /dev/ttyACM0 removed 
[20201228 11:43:11.913 CST] [ozw.manager] [debug]: Driver Removed for  "/dev/ttyACM0" 
[20201228 11:43:11.913 CST] [ozw.manager] [debug]: OZW Serial Port Closed 
[20201228 11:43:11.913 CST] [ozw.daemon] [info]: Shutting Down  "ozwdaemon"  Version:  "0.1.0" 
[20201228 11:43:11.913 CST] [ozw.daemon] [info]: OpenZWave Version:  "1.6.1545" 
[20201228 11:43:11.913 CST] [ozw.daemon] [info]: QT-OpenZWave Version:  "1.2.0" 
[20201228 11:43:11.913 CST] [ozw.daemon] [info]: QT Version:  5.12.5 
[20201228 11:43:11.913 CST] [ozw.daemon] [info]: Exit Reason:  EXIT_MQTTDISCONNECTED 
[20201228 11:43:11.913 CST] [ozw.daemon] [info]: Please consult log messages for specific error messages if any 
[20201228 11:43:11.921 CST] [ozw.manager] [info]: New Client WebSocket Connection QHostAddress("::ffff:") 
[20201228 11:43:11.922 CST] [ozw.manager] [warning]: WebSocket Client Error  QAbstractSocket::RemoteHostClosedError 
[20201228 11:43:11.922 CST] [ozwadmin] [debug]: Remote Connection Status:  QTOZWManager::ConnectionErrorState QAbstractSocket::RemoteHostClosedError 
In exit
[cont-finish.d] executing container finish scripts...
[cont-finish.d] executing... 
1609177391: mosquitto version 1.6.8 terminating
1609177391: Saving in-memory database to /data/mosquitto.db.
[cont-finish.d] exited 0.
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.

What are my next steps in troubleshooting?

Try restarting… (few times)

Dont use the vnc or addon in homeassistant.

Instead download the (windows) openzwave client.

Thanks, I was able to get connected with a windows openzwave client. I’m still experiencing the same issue though. The log always looks the same. I’m wondering if


is the key? I haven’t really done anything with MQTT yet. Is there an MQTT requirement?

YES. Install the mosquitto mqtt addon…

(Have you read the docs???)

I did read the documentation. I was using the internal MQTT broker and the tests were working from the integration page. I checked the docker containers and noticed a lot of MQTT stops and starts. If I try to install and start Mosquitto I (not surprisingly) get a port conflict. I guess my question should be, is the internal MQTT sufficient or do I need to disable it and install a different broker?

There is no internal mqqt…? What do you mean?

I didn’t have to install an addon, it’s available in integrations with the default install

There seem to be two ways to add the Mosquitto broker into HA:

  1. From the Supervisor > Add-on Store and
  2. From the Configurations > Integrations > Add Integration

It’s not clear to me whether the broker ends up being configured exactly the same, or whether the configuration depends on the route chosen.

I chose route (1) for my OpenZWave (beta) setup and it works.

That’s how I did it as well, although not with success. I might rebuild with Debian 10 instead of Ubuntu so I can get rid of the unsupported warnings and try again.

AFAIK you only need to have mosquitto installed. As an addon. And then openzwave (beta) will pick it up automatigally.

And yes ofcourse homeassistant needs to know how to reach mqtt thus you will need to enable the integration.

You no longer need the MQTT integration installed for a Supervisor installation, only for Core.

Thats “some news”… is there any update on the addon (coming)?

It’s already implemented. That’s why the docs split the requirements based on installation type.

Although, I’m not sure you can just go and remove the MQTT integration if you’re already setup. I think it is determined when the OZW integration is installed.

I did a clean install of Debian 10 instead of Ubuntu 20.04 and installed the Mosquitto addon instead of the broker available in integrations and the zwave addon is now working and stable.

Thanks for the pointers.

It caused me some issues the other day. I just deleted and installed the ozwave integration and it fixed itself. Had to rename everything which was a pain in the ass but it’s been working fine since.

@petro huh? In the other topic ozw was very solid with no issues!?

I caused the issue by attempting to make my own MQTT sensors. Stop trying to fuel the fire it’s childish, it was my own doing. You’re welcome to check out my chat history on discord regarding the issue I created.

I’m not! I am trying to find the real rational behind. Sometimes I really do not understand all opinions and angles (and possibly hidden calendars).