Zwave devices missing


i just experienced another zwave device went missing from my configs… this happened once before when i was using hassbian… now on hassio.

any help on how to prevent this from happening would be appreciated.

i have tried a couple reboots.


Missing? Not showing up at all in states (<>)?

yup… not showing up…

gone! :frowning:

should i delete the zw** config file?

Try renaming it to something like zwcfg_*.xml.backup (after you’ve shut down Home Assistant) and then starting HA. It might well be that for some reason your Z-Wave stick is forgetting about it, which would suggest a faulty stick.

thanks, just tried it. and seems it got worse…

no more zwave devices… did a couple reboots one of the devices is back… and so is the config file… will give it some time and reboots i guess…

another couple reboots…

now i just have 2 zwave entities correctly identified …

please help!

i reverted to the old config file… and have all the devices i had before are there… except for the one missing one …

Honestly? It sounds like you’ve a problem with the Z-Wave stick.

Devices showing up as Dead indicates a mesh problem, or that a previously included device is physically missing. Having a device not show up at all suggests that the controller (your Z-Wave stick) has forgotten about it, which indicates a controller fault.

i am thinking i’ll dedicate time this weekend to hard reset the Zwave stick and hope for the best…

whats the right way to be able to rename the entity of a zwave device?

i am trying to re-add the switch it shows up as switch.switch.

I want to rename it and have it save…

Also can the zwcfg*** file be manually edited to have this information persist ?


Open the control panel, select the node under Node Management, enter the new name and push Rename Node.

Then when you shut Home Assistant down the names will be saved in zwcfg*.xml.

thanks! that did it

I added the one node back in…

i still have 1 “orphan” node that i want to get rid off… tried to do a remove node and a remove failed node both fail.

You can only remove the node if it’s currently included, and remove a failed node if it’s marked as failed.

thanks… there is definitely an orphan node … not sure what to do with it.

Leave it and eventually it’ll be flagged as failed. At that point you can remove it with the Remove Failed Node option.

In the mean time, you could use customize to hide everything but the zwave entity itself.


unrelated question…

i am trying to add gocontrols… door sensor … should i add them as a secure zwave node or non-secure standard zwave node

As mentioned in the documentation, always use Add Node Secure for devices that support Secure - anything else runs the risk that it won’t fully function.