Zwave devices not updating state after manual press

I’m not sure when exactly this started, but zwave devices that are not directly connected to my controller (zstick) will not update their state if I manually flip them. The ones that are just one hop away (yellpw) update in real time. Everything that’s two hops (green) will only update state if I change it from hassio.

I can test it with both some GE switches and outdoor switches. No errors in the zwave log. Any ideas on how to troubleshoot?

Separately, I really wish we could get back the ability to rename nodes.

Have you looked in your z wave configuration for the devices to see what the reporting type is?

I had a couple of z wave switches (Aeotec G2 switches) that I needed to update the report type as “Hail”. That fixed the similar symptoms for me that you are experiencing.

Me Too!! :wink:

Can you provide more details on how to set to reporting type to “Hail?”

I’m having this issue as well.

There seems to be an appropriate message come through the OZW log:
2018-12-13 11:37:26.091 Info, Node010, Received Basic set from node 10: level=99. Sending event notification.
2018-12-13 11:37:26.091 Detail, Node010, Notification: NodeEvent
2018-12-13 11:38:07.403 Detail, Node010, Received: 0x01, 0x09, 0x00, 0x04, 0x00, 0x0a, 0x03, 0x20, 0x01, 0x00, 0xda

However, the HA web interface does not show the state change after manually pressing the switch. If I “refresh node” in the Z-wave configuration, then HA does show the correct/current state.

Looks like that isn’t an option for the GE switches. I have a couple Aeon micro switches and looked there. Under configuration->Z-Wave->Select Node->Node Config Options->Notification Status. The Aeon swithc has options for Hail, None, or Basic. I just switched that to Hail and will see if it starts updating. The only Node Config Options for the GE switches are Night Light and Invert Switch.

Thanks for the reply. Unfortunately I don’t have that setting either. Frankly I’m a little puzzled why its not working the way it is currently. As I mentioned earlier OZW does seem to see the state change sent from the Z-Wave device, as far as what the log shows, its just that Home Assistant doesn’t pick up on that and show the updated status in the web interface. I know all of these Z-wave devices do support the association command class, and I had instant status updates with my previous setup (SmartThings). The only thing I did was get rid of SmartThings and remove/re-add all of the devices to the new Z-Stick Gen5 via Home Assistant.

I know this is a VERY old topic. But was there a resolution? I am having the exact same issue and am getting frustrated. Smarthings worked well and I recently purchased a Z-stick Gen5 to get more control and I am having all sorts of issues with the node not updating in home assistant


Did you ever found a solution?

1 Like

Hello, just started with HA and got the same problem, >what is the solution to this.
If i press the button of the light switch the etentities is not updating , if i change the itentities from withing HA it works perfectly , problem is that if not updating , automation is not working . thanks
the swithes where it is not working are hopped via another node

what’s the model number on the switches/dimmers? Older zwave switches and dimmers require polling. This is because the devices were created before the lutron patent was lifted in 2017 that blocked companies from making ‘instant update’ zwave switches and dimmers.

wel its the Neo CoolCam Wall Switch CH 1
seems that it is hardware related .
Found this thread on the internet Neo CoolCam Wall Switch problem - Domoticz
There is a solution and will try it out . (need to remove group and add again in z-wave)

ok found the problem

added Switch Status Report NodeID_1 None and now the device is reporting . i hope this helps for others