Zwave failing after re-start

Hi, wondering if anyone can point me in the right direction.

I’ve successfully setup a zwave aeotec_zw090_z_stick_gen5 and paired a four way sensor. I was reading values from it, until I had to do a restart.

My Z stick seems to be stuck at "initializing (Neighbours) and consequently the sensor is showing “entity not available”. A screenshot is attached.

It seems as though i spend a lot of time configuring and trouble shooting this setup only to have it fail each time a reboot (I had different errors previously).

I can see both the ‘Z stick’ and the sensor in the “Z-Wave Node Management” Nodes drop down. But nothing is happening. What am I doing wrong?

I’m running in a docker environment.

Thanks for any assistance.


How long have you waited?
It may take a little while for z-wave to be ready after rebooting (although it should be short with the low number of devices you have)

About twenty hours now. Now the Z Stick is status has changed to “Unknown”.

I’ve obviously got something wrong here.

  1. I run the command “hassio hardware info”.

  2. I can see a device “/dev/ttyACM0”. I gather that is the USB Z wave controller.

  3. “ls -al /dev/ttyACM0” gives me: crw-rw---- 1 root dialout 166, 0 Feb 6 14:04 /dev/ttyACM0

  4. I have the following in configuration.yaml:

usb_path: /dev/ttyACM0

  1. No nodes are listed in the Z-Wave Network Management panel.

It should be there right? Do I need some sort of docker pass though somewhere? Running all commands on the Z-Wave panel just gives me a “failed to call service error”.

I just don’t see what is wrong.

I deleted the zwave entry out of configuration.yaml and deleted zwcfg_0xe99dbe10.xml and zwscene.xm.

Restarted, added the zwave entry to configuration.yaml and restarted again. The Z stick and the sensor is now back.

I’ll let it be for while, don’t know if they’ll be back after a restart though.

I performed an update and the zwave entities remained after the restart.

Added the system health component to configuration.yaml, performed a restart and now they’ve gone. Completely, not event present under the Z-Wave Node Management panel.

Sometimes its there, sometimes it isn’t. Just doesn’t seem to be any rhyme or reason to it all.

Hang on, they’re back. Perhaps what is lacking is patience!

Did a reboot, lost everything again. Repeated by removing z-wave competent and associated files and rebooted again. Got the z-stick back, unable to include the sensors back in. Hopeless.

I have the same issue, did you ever fix it?

The Z stick came up by itself after and update and reboot. I’ve managed to reconnect one sensor, the others refuse to join. More trouble than its worth I reckon.

Did you guys ever find any solution? I ran into the same thing when switching HA from my PI to ubuntu. I have tried many things- nothing so far other than:

Turning on ubuntu from a cold start NEVER works. Once HA is up the only way to get the zwave back and working again is to do a REBOOT. And you can’t do it right away- you have to wait a few minutes. If you reboot right away you get nothing or just a few nodes with errors. Wait a bit and you get everything back…

I found one thread where someone had same issue but he fixed it by started over from scratch . New HA and exclude and include zwave all devices,

I may do that eventually- just want to make sure first this is not do to running zwave under ubuntu vs pi (ie thats the best it gets)

So did you ever find a fix?

Nah, never did get it to work properly.

I’m having same issues. Z Wave seems promising, but it just keeps failing. Has anyone thought of just going with wifi switches and dimmers?

I was having the same issue with a Raspberry Pi 3. The only way I can fix it is a full power cycle instead of a restart. Hopefully this helps someone.

1 Like