Zwave instruction are incorrect

If you following the instructions on this page…

https://home-assistant.io/getting-started/z-wave/

… then python-openzwave is installed at /home/pi and this is completely incorrect. At least from what little I know it is incorrect.

My question is simple. What directory should you be in when you execute the github build/make. Again, if you following this you are in /home/pi since it never tells you to switch to anything else.

To save you from going to the page here are the complete instructions.

Make sure you have the correct dependencies installed before running the script:

$ sudo apt-get install cython3 libudev-dev python3-sphinx python3-setuptools git
Make sure you have at least version 0.23 and at the most 0.24.1 of cython.

$ sudo pip3 install --upgrade cython==0.24.1
Then get the OpenZWave files and switch to the python3 branch:

Do not use root to build python-openzwave as it will surely fail.

$ git clone https://github.com/OpenZWave/python-openzwave.git
$ cd python-openzwave
$ git checkout python3
$ PYTHON_EXEC=$(which python3) make build
$ sudo PYTHON_EXEC=$(which python3) make install
Instead of make install, you can alternatively build your own python-openzwave package which can be easily uninstalled:

$ sudo apt-get install -y checkinstall
$ sudo PYTHON_EXEC=$(which python3) checkinstall --pkgname python-openzwave --pkgversion 1.0 --provides python-openzwave
With this installation, your config_path needed below will resemble:

/usr/local/lib/python3.4/dist-packages/libopenzwave-0.3.0b8-py3.4-linux-x86_64.egg/config
If you followed along with setting up a virtual environment, your path will be:

/srv/hass/python-openzwave/openzwave/config

Also the /hass directory is not correct. Someone pointed out that they changed it to /homeassistant in December. This documented is outdated as well.

1 Like

I ran the sudo PYTHON_EXEC=$(which python3) make install again and I appear to have it installed in the correct location now. But the install directions are still outdated that mention hass

I am marking this complete.

You should update the documentation.

2 Likes

Which directory did you start in? That’s the first thing i noticed, that the directory wasn’t mentioned.

I start in base directory.
If make here it installs in the home directory of user executing command…So ‘/home/[your user]’

So you are referring to the HA user directory? On hassbian that’s home/homeassistant.

I did the make/build inside the home/pi directory and that did not work.