Zwave intergration error after moving to HassOS

Today i was moving from a unsuported Ubunutu installation to the HassOS version.
I made a full snapshot and used this to recover everything within the clean HassOS instal.
Everything seems the be working fine, except the Z-Wave JS integration, it tells me : Retrying setup: Z-Wave JS Server version is incompatible: 1.2.1 a version is required that supports at least api schema 4

when i click at the devices the all show up, and seems to be working fine, but how to solve this error ?

Upgrade whichever addon you’re using that provides the zwave-js server: Z-Wave JS Addon, ZWaveJS2MQTT addon, docker container, etc.

Hey there, everyone…
My problem w/ Z-wave commenced when I had to rebuild from fresh scratch on a Raspberry Pi4B. Followed all the instructions for the initial install, added the add-ons from the previous setup which was on a RPi3B+. All is good except for the z-wave stuff.

What I have since discovered is that the initial installation has marked the filesystem as read-only, thus making the required files and folders not present. Also, the system shows /dev/ttyAMA0 present regardless of whether my Aeotec Z-stick Gen5 is plugged in or not.

Not being a linux-savvy person, I could use some guidance in how to set my filesystem read/write. Putty’s set up as is the terminal/ssh addon and as I said, all works as I would like. Fortunately, I’ve got a Samsung SmartThings hub which handles both zigbee and z-wave. If not for this, I’d really be hosed

Any tips would be deeply appreciated.

okay but all add-on are the most recent ones , so how to update these again ?
I already tried to re-install the Z-Wave JS (after uninstall) , and installed the ZWaveJS2MQTT , but still the same error

Well, after collecting information via dmesg, I discovered that this installation of HassIO uses SquashFS for the root filesystem, which I learned also is interently read-only. I found no errors related to the sd card, a brand-new scandisk 32Gb device.

So, unless there’s a way to change this behavior, I cannot use the Z-wave JS integration or any of the z-wave addons. The system will not detect the presence of the z-wave stick.

Your stick should be available on /dev/ttyACM0 and not the ttyAMA0 you mentioned. As for the filesystem I’m unsure what’s going on there…

I think this is a different question then mine ? So could you please open a topic yourself :wink: ?

it is on /dev/ttyAMA0.

That’s the Bluetooth of the Pi 4. You probable have an older Aeotec stick that requires use of a non-powered USB 2.0 hub to actually work, hence it not working at this point.

whatever i did, this doesnt help , still the : Retrying setup: Z-Wave JS Server version is incompatible: 1.2.1 a version is required that supports at least api schema 4

Using the Zwave JS add-on, so is there a way to upgrade this ?

What version of the add-on are you using? It looks like you still haven’t upgraded it properly.

Z-Wave JS Server version 1.2.1 was originally included in add-on version 0.1.13 (more than two months old).

As of today, the add-on version is 0.1.23 and it includes server version is 1.7.0.

i can;t find any way to push/ force update. I delete and re-installed it but nothing .
So i think i will start with a clean install

I am getting a similar error in Configuration/Integrations:

“Z-Wave JS
Retrying setup: Z-Wave JS Server version is incompatible: 1.5.0 a version is required that supports at least api schema 5”

I haven’t made any changes to anything; my Z-Wave devices just became “Unavailable”

There are no Logs, and the dump of zwave_js_dump.json returns, “Failed - No File”.

In Supervisor/Z-Wave JS/Info it states:

“Z-Wave JS
Current version: 0.1.21”

I restarted the Z-Wave JS Server, and rebooted the Host, but I don’t see any way to request an update.

Is there any way to fix this problem?


I’ve also got the same error, since upgrading from 2021.6rc2 yesterday to released version 2021.6.x.

Have tried to uninstall and re-install Zwave JS, but error persists, even after a full reboot.

i tried a lot of things, but only a clean install was helping me solving this issue