Zwave JS - Cannot start inclusion

Hey All

I’m a newbie, so please go easy on me :wink:

My challenge :

  • I am trying to add a aeotech gen 5 usb stick (pi version) to my HA setup.
  • from the online documentation it seems its recommended to use the zwave js
  • I’ ve managed to install the integration “zwave js” and it finds my stick
  • When I go to configure to add a node I click " add node" , which then pops up another screen. I click on “start inclusion”
  • Nothing happens… literally
  • i can see the UI button has being pressed , but nothing happens at all

What am I doing wrong ?

My setup as follows:
pi 4 8GB, 128 SD card
HassOS 5.5

I also saw this in the logs - unsure if its related or not

Logger: homeassistant.components.websocket_api.http.connection
Source: components/websocket_api/
Integration: Home Assistant WebSocket API (documentation, issues)
First occurred: 10:17:54 PM (1 occurrences)
Last logged: 10:17:54 PM

[548057186752] Received invalid command: zwave_js/add_node

Can anyone help at all ? Please let me know if you need any other info too


PS I’m not developer, this is a hobby so you may need to dumb things down for me :wink:

Was this stick used previously (either by you or maybe a used purchase?). I had a backup zwave stick that I was playing around with today and it was giving me tons of trouble with inclusion failing until I factory reset the stick. It had a previous configuration on it from when I was messing around w/ it years ago. Once I removed all the associated nodes w/ a zwave config utility (z-wave pc controller that I found online), everything worked fine.

I don’t know if that’s your issue, but I had the exact same problems and the reset resolved everything for me.

hey @breakthestatic - thanks for your reply.
The stick was brand new. After a few more resets of the sticks and hard reboot of my pi, things seem to start working. How odd

Consider this closed for now

I had exactly the same issue to start with. For me, it was an old stick but I had already factory reset it before using it with HA. I have HA OS running in a VirtualBox machine on a Mac and I tried to reboot the HA VM to try to fix the issue but then the VM wouldn’t boot. So I rebooted the Mac itself and that seemed to fix it. VM now boots and I successfully included a ZWave node. Very odd.

Having this issue too. A reboot solves it temporarily (restarting core and/or z-wave js does not).

There’s no feed back in the browser’s javascript console or anywhere else (that I am aware of - still relatively new to HA.)

Have a look here, your stick might be in the wrong mode needs to be in suc… read here