Zwave js failed to connect on pi

I had this working on the first install but after trying to redo the setup I’m not able to get it working.

I’m running this on a typical raspberry pi setup without docker. I just can’t get the device/integration to install no matter what I do.

Does this mean HA Os with the HA addon or you install Zwave js on pi and connect from other server?

I’m just gonna guess and say your connecting to wrong ip.

Try ws://a0d7b954-zwavejs2mqtt:3000

Here it says use that for addon as shown below

It’s unclear how you’ve installed everything to me so this WAG may be completely wrong

If you’re not running the supervisor or you’ve unchecked the above mentioned box, you will be asked to enter a websocket URL (defaults to ws://localhost:3000). It is very important that you fill in the correct (docker) IP/hostname here. For example for the Z-Wave JS to MQTT add-on this is ws://a0d7b954-zwavejs2mqtt:3000 .

Did you get this working? I am having same problem after moving from pi3 to a pi4. Always get a failed to connect message when installing the integration