Zwave JS - Fibaro wallplug

I have installed today Zwave JS (moving with a fresh install after the Zwave deprecated HA environment). I have a lot of Fibaro wallplug. I have succesfully added them. I have two issues:

  1. I cant’ see always the update when I manual switch on the wallplug
  2. I don’t see the Wattage usage back in HA. Everything stays 0, but I see in the logs of Zwave JS this:
 2021-05-30T19:07:22.542Z CNTRLR   [Node 002] [Multilevel Sensor] Power: metadata updated            [Endpoint 0]
2021-05-30T19:07:22.546Z CNTRLR   [Node 002] [~] [Multilevel Sensor] Power: 2.1 => 1.3              [Endpoint 0]
2021-05-30T19:07:22.549Z SERIAL » [ACK]                                                                   (0x06)
2021-05-30T19:07:22.551Z DRIVER « [Node 002] [REQ] [ApplicationCommand]
                                      type:  Power
                                      scale: Watt
                                      value: 1.3

Any idea why I don’t see this data back in HA?

I assume you installed the ZWaveJS Integration. What are you using in the Supervisor? ZWaveJS or ZWaveJS2mqtt? Either one will work but the latter gives a better control panel UI.

Yes correct. I am using the supervisor with ZwaveJS integration (with ZwaveJS and not 2mqtt)

OK I am using the 2mqtt one with WebSockets. I am still trying to get back into HA after a 2 year absence over at openHAB.

Try re-interview node, I have few Fibaro plugs, and they are working fine on zwaveJS(instant state change, watt report,…)

Thanks, did that already with two of them, but no luck. But I see the wattage back in my log of the Zwjave JS supervisor log. What firmware do you have of the wallplug?

I have: Firmware: 25.25

25? Are you sure?
I have 3.2 firmware

Yes, all six of them show this:

What Fibaro models? The device database shows only FGS214 & FGS224.

They are probably the FGWPE/F-101 wallplugs (which are in the database).

I am also not seeing the realtime wattage consumed, but I do see the total kWh being recorded, and the power readings.

Manually switching of the plugs do seem to be registered in HA for me.

I’m using the ZWave JS server with the ZWave2mqtt control panel.

That looks to be a bug but many software pieces are involved…

I think the proper first step is to file a GitHub issue with the zwavejs2mqtt HA integration.

I have FGWP102

That does not appear to be in the zwavejs database. That is likely your issue.

I think some of the information can be imported from the opensmarthouse database used by openHAB and added to the database for a future update… I have not researched this well though.

EDIT: You said it is in the zwavejs logs so the database is not likely the issue, but an integration one.

Try opening an issue for the zwavejs integration with HA.

See Fibargroup

1 Like

Yeah, I forgot about the 2 different manufacturer IDs.

@Remco_Ploeg Did you ever manage to solve the power reporting from the fibaro plug?

This is still not working for me for the newer firmware version of the Fibaro wallplugs…

Fibaro wallplugs with firmware 25.25 do seem to be providing power usage data which is being recorded in HA, but the newer wallplugs with firmware 3.2 are still returning zero values…

Edit: I’ve found that it is two of the wallplugs with firmware 3.2 that are not returning values - three others with 3.2 are working correctly.

I’ve tried re-interviewing the nodes, but this has not cured the problem…

Sigh - user error again. My wallplugs with 3.2 firmware are in fact all working correctly. Sorry…

I have the same issue.

All plugs have been working correctly with live data untill a couple days ago when ai updated to the latest ZwaveJS version.