zwave-JS firmware update (stuck)

Hi everyone,

recently I started to have battery issues on my aeotec temperature sensors (ZWA039) running fw 2.1.1
I tried to update this even with an external controller tool, but failed.

out of a sudden I found today, that some devices on my zwave network popped up in Settings > Updates
So obviously the zwave-js update function evolved and finds the newer fw on its own.

However, I started updating the first device more than one hour ago and it’s stuck at 10% and not moving.
I woke the device a few times (with the first wake-up it started from 0 to 10%), but it’s stuck.

What is the best way to proceed as there is no cancel button or similar.
Should I do a restart of HA (and zwave) or what is the recommandation of more experienced zwave users :smiley:

1 Like

What I did was to do a complete restart of HA and pull the battery on the sensor. Start the process again. One of my Zooz temp sensors took like 3 tries for some reason. I think there is a way to just restart zwave-JS but I can’t remember how.

Thank you.
I did not take the battery out yet.

However I reloaded the zwave-JS integration (just do so in settings > devices > zwave > three dots > reload), but it did not help.
Even after a restart HA complaints, that there is an update in process (z-wave error 1508).
(but the sensor does not show any update activity in the UI) :frowning:

1 Like

I have the same issue. I started updating and stopped updating, and now it just hangs with an available update but no progress at all. If I find the solution, then I will share.

1 Like

Thanks!
After a several days and reboots, the update progress was obviously stopped unsuccessfully.
On other devices I haven’t been able to update either. :frowning:
I will continue to try though.

EDIT:
I tried again with a mains powered device (AEOTEC Range Extender ZW189-C15), but the update stopped at 50% without any error or other notification.
It just went back to the UI showing the old and the new FW version:

I was monitoring the screen the entire time and wonder how it should look like.

Any updates on this? Have some firmware I’ll need to update, but won’t try if it’s still broken

After a few attempts I have successfully updated the Aeotec Range extender as well as the Aeotec Temperature and Humudity sensors.
I did not try to update others than Aeotec though.

1 Like

Not a solution as such, but you can clear the queued firmware update by removing your Zwave stick from the USB.