Zwave-JS Include/Exclude failure

When trying the include or exclude from the ZwaveJS integration page, I am getting the following error in the logs.

17:53:37.498 CNTRLR   starting inclusion process...
17:53:37.527 CNTRLR   handling add node request (status = Failed)
17:53:37.528 CNTRLR     starting the inclusion failed
17:53:37.529 CNTRLR   stopping inclusion process...
Unexpected error ZWaveError: The inclusion could not be started.
    at ZWaveController.handleAddNodeRequest (/usr/lib/node_modules/@zwave-js/server/node_modules/zwave-js/src/lib/controller/Controller.ts:970:7)
    at Driver.handleRequest (/usr/lib/node_modules/@zwave-js/server/node_modules/zwave-js/src/lib/driver/Driver.ts:1902:33)
    at Driver.handleUnsolicitedMessage (/usr/lib/node_modules/@zwave-js/server/node_modules/zwave-js/src/lib/driver/Driver.ts:1638:16)
    at Object.notifyUnsolicited (/usr/lib/node_modules/@zwave-js/server/node_modules/zwave-js/src/lib/driver/Driver.ts:487:16)
    at notifyUnsolicited (/usr/lib/node_modules/@zwave-js/server/node_modules/zwave-js/src/lib/driver/SendThreadMachine.ts:564:19)
    at Interpreter.exec (/usr/lib/node_modules/@zwave-js/server/node_modules/xstate/lib/interpreter.js:657:24)
    at Interpreter.execute (/usr/lib/node_modules/@zwave-js/server/node_modules/xstate/lib/interpreter.js:206:22)
    at Interpreter.update (/usr/lib/node_modules/@zwave-js/server/node_modules/xstate/lib/interpreter.js:226:18)
    at /usr/lib/node_modules/@zwave-js/server/node_modules/xstate/lib/interpreter.js:125:23
    at Scheduler.process (/usr/lib/node_modules/@zwave-js/server/node_modules/xstate/lib/scheduler.js:60:13) {
  code: 21,
  context: undefined,
  transactionSource: undefined
17:53:37.597 CNTRLR   handling add node request (status = Done)
17:53:37.598 CNTRLR   done called for 26
17:53:37.599 CNTRLR   the inclusion process was stopped

Thats kind of low in information. Did that node 26 get added or not? (and many more questions of your exact situation, try filling them in pls)

Resolved by doing an add-on reinstall then OS reboot.

I am seeing the same issue after recent zwavejs2mqtt updates, inclusion directly stops with an API error. I tried removing and re-installing, rebooted as suggested but it still refuses to add anything.

2021-04-14 23:04:44.251 INFO ZWAVE: Node 55: value updated: 50-0-value-65537 121.39 => 121.39
2021-04-14 23:04:44.370 INFO ZWAVE: Calling api startInclusion with args: [ false, [length]: 1 ]
2021-04-14T21:04:44.373Z CNTRLR starting inclusion process…
2021-04-14T21:04:44.451Z CNTRLR handling add node request (status = Failed)
2021-04-14T21:04:44.452Z CNTRLR starting the inclusion failed
2021-04-14T21:04:44.453Z CNTRLR stopping inclusion process…
2021-04-14 23:04:44.460 INFO ZWAVE: The inclusion could not be started. startInclusion { success: false, message: ‘The inclusion could not be started.’ }
2021-04-14T21:04:44.517Z CNTRLR handling add node request (status = Done)
2021-04-14T21:04:44.519Z CNTRLR done called for 0
2021-04-14T21:04:44.520Z CNTRLR the inclusion process was stopped
2021-04-14 23:04:44.520 INFO ZWAVE: Controller status: Inclusion stopped
2021-04-14 23:04:44.868 INFO ZWAVE: Node 50: value updated: 50-0-value-65537 3.56 => 3.56

I still have this issue… Have re-installed, restarted etc… All previous added nodes comes back but I can’t start inclusion… Directly when I click the button I get the stack trace in the logs saying:

Z-Wave error ZWaveError: The inclusion could not be started.

Anyone have any ideas apart from removing and restarting?

I just found out I’m in the same situation so I stumbled upon this post. Do you happen to use ZQ090 by AEON Labs “Z‐Stick Gen5 USB Controller”?

If so @ozbob01 mentioned a possible fix here: Zwave JS - Cannot start inclusion - #4 by JonD117
Link to proposed fix: Aeotec support article

I haven’t tested doing this myself yet. I find it odd, as I have included devices previously when using z-wave js. Last inclusion was some months ago, so I’m not sure which version worked for me.

My setup:
Raspberry PI4
Home Assistant Core: core-2021.6.1
z-wave js: 0.1.24
I’m not using zwavejs2mqtt

Edit: updated to core-2021-6.2 (which reboots the system), and I was able to add the device.

I had similar issue. Unplugging and replugging the ZStick was what worked for me:

I have tried all solutions above with no luck… I’ve had this same issue before but I can’t remember what I did to fix it. Man, Z-Wave has been annoying, wish I stuck with ZigBee.

Just FYI, i removed the stick added the device and then plugged it back into HA. That worked.