Zwave JS integration fails to install

After upgrading to 2021.2.3 I decided to migrate to zwave JS.
I’ve tried the default zwave server and the zwave2mqtt server. The device is connected. They start listening to port 3000 it seems.
However I cannot get either of them to work when installing the Integration zwave JS.
With zwave2mqtt I remove the checkbox and manually added the 358734958-zwave2mqtt name or the ip-address of the docker 172.30.x.y. but neither worked.
The native zwave also did not work.
If I look at does not export the port 3000. But I guess it should via supervisor/internal?
When I try to add the zwave js integration I get an unexpected error.
The log says:

Source: components/zwave_js/
Integration: Z-Wave JS (documentation, issues)
First occurred: 2:53:55 PM (3 occurrences)
Last logged: 3:23:50 PM

Unexpected exception
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/zwave_js/", line 106, in async_step_manual
    version_info = await validate_input(self.hass, user_input)
  File "/usr/src/homeassistant/homeassistant/components/zwave_js/", line 45, in validate_input
    return await async_get_version_info(hass, ws_address)
  File "/usr/src/homeassistant/homeassistant/components/zwave_js/", line 56, in async_get_version_info
    version_info: VersionInfo = await get_server_version(
  File "/usr/local/lib/python3.8/site-packages/zwave_js_server/", line 11, in get_server_version
    return VersionInfo.from_message(await client.receive_json())
  File "/usr/local/lib/python3.8/site-packages/aiohttp/", line 291, in receive_json
    data = await self.receive_str(timeout=timeout)
  File "/usr/local/lib/python3.8/site-packages/aiohttp/", line 276, in receive_str
    raise TypeError(f"Received message {msg.type}:{!r} is not str")
TypeError: Received message 257:None is not str

I’m running on raspberryPI 3+with raspbian 10 buster and docker 19.03.12. Home assistant 2021.2.3. Supervisor 2021.2.9.


No. That results in unexpected error. (sorry I did not give the exact name but it was the same name as the addon showed)

Hi, Not sure it is the right place to post this.
So I have Z-Wave JS 0.1.7 add on install (on Debian 10 machine supported install type).
In supervisor it shows that Z-Wave JS 0.1.8 is available but the update button is greyed out.

Supervisor log states “21-02-25 08:20:28 ERROR (MainThread) [supervisor.addons] Add-on core_zwave_js not supported on that platform”

Have I done something wrong?

Additional message on the add on info page:

You are running Home Assistant 2021.2.3, to install this add-on you need at least version 2021.2.0b0 of Home Assistant

That should read 2021.3.0b0 - it was a typo in the original message.

I can only confirm I get the exact same error message. Seems to be an issue with the version checking.

Message when trying to update the addon:

You are running Home Assistant 2021.2.3, to update to this version of the add-on you need at least version 2021.2.0b0 of Home Assistant

We will have to wait until next Wednesday. See the discussion about this issue on Github.