Zwave JS Keeps Failing

A few days ago my Z-wave network stopped working and I can get it back up and running, but within a few hours, the Z-wave JS integration says failed, and will try to reconnect. If I restart the addon, it’ll start working again for a few hours, then end up back in the same loop of crashing. It may have been coincidental, but I added a RTL_433 addon and SDR Dongle to try pick discover a RF device that I have, with no luck, then I noticed shortly after my Z-wave network was down. I ultimately restored a backup of before I started messing with the RTL433 and still having same issue with Z-wave.

My Hardware is:

HA: HA Green
Z-Wave Hub: Nortek GoControl CECOMINOD016164 HUSBZB-1 USB Hub

My Nortek is the combo stick so Zigbee and Z-wave. The Zigbee network is fine, still functioning.

I’ve tried multiple restarts of the addon and as I said above, it’ll start working again normal for a few hours, then back to failing to connect. I’ve tried unplugging re-plugging, rebooting, restarting. I haven’t tried actually turning HA off yet. In the Configuration I set Soft Reset to disabled as something I read recommended, but still ends up same issue. I’ve also ordered the Zooz 800 USB controller, but after tinkering around, I’m starting to think its not the Nortek controller, but just the Zwave JS addon, but I could be wrong. Below is the last thing in the Logs that seem relevant.

2024-05-23T05:04:54.053Z DRIVER   Serial port errored: The serial port closed unexpectedly! (ZW0100)
Error in driver ZWaveError: Serial port errored: The serial port closed unexpectedly! (ZW0100)
    at Driver.destroyWithMessage (/usr/src/node_modules/zwave-js/src/lib/driver/Driver.ts:2899:17)
    at ZWaveSerialPort.<anonymous> (/usr/src/node_modules/zwave-js/src/lib/driver/Driver.ts:1141:15)
    at ZWaveSerialPort.emit (node:events:517:28)
    at SerialPort.onClose (/usr/src/node_modules/@zwave-js/serial/src/ZWaveSerialPort.ts:36:14)
    at Object.onceWrapper (node:events:632:26)
    at SerialPort.emit (node:events:517:28)
    at port.close.then.closing (/usr/src/node_modules/@serialport/stream/dist/index.js:242:18) {
  code: 100,
  context: undefined,
  transactionSource: undefined
Shutting down
Closing server...
Client disconnected
Code 1000: 
Server closed
[05:04:54] WARNING: Halt add-on
s6-rc: info: service legacy-services: stopping
s6-rc: info: service legacy-services successfully stopped
s6-rc: info: service legacy-cont-init: stopping
s6-rc: info: service legacy-cont-init successfully stopped
s6-rc: info: service fix-attrs: stopping
s6-rc: info: service fix-attrs successfully stopped
s6-rc: info: service s6rc-oneshot-runner: stopping
s6-rc: info: service s6rc-oneshot-runner successfully stopped
s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service fix-attrs successfully started
s6-rc: info: service legacy-cont-init: starting
cont-init: info: running /etc/cont-init.d/
[07:28:31] INFO: Both 'network_key' and 's0_legacy_key' are set and match. All ok.
[07:28:38] INFO: Soft-reset disabled by user

The new Zooz 800 Controller will get here today and fortunately I only have like 9 Z-wave Devices that I’m using through the controller, so going around resetting and re-adding to new hub wont be terrible, but I’m concerned that It’ll be all for nothing if its just the Zwave JS addon.

I highly doubt it’s ZWave2JS that is the problem here. The Nortek sticks are old and most likely the ZWave radio is just on it’s way out. If your Zigbee radio is still functioning, then I don’t think the entire device is dead, just the radio itself. I have one of the Nortek sticks still running my ZWave network, but my Zigbee radio died ages ago.

That would be unfortunate, but also a relief. I’ll plan on setting up the new Zooz stick and hopefully that’s the cure.

Yeah, if you continue to have problems with the new coordinator, then I would start to look at Z2JS, but generally, the app itself is responding as it should.

I’ve only had HA and the Nortek stick for like 3 months, if it’s the coordinator, pretty crappy lifespan.

That Nortek stick is old. They discontinued them in 2019 (IIRC), so you’re not getting “new” hardware. It’s been sitting on a shelf somewhere for a long time probably.

Got the new Zooz stick installed and the network rebuilt. So guess it’s just a waiting game to see if the issue repeats itself again. Fortunately if this does solve the issue, the Nortek stick was still working for Zigbee so now I have two independent radios.

1 Like

There ya go and it’s exactly what I do (in reverse).

My Zwave network survived the night. Something hasn’t done in like 4 days. So this is definitely seeming that the Nortek Zwave radio was the failure and I’m all good to go with the new stick. Hopefully didn’t jinx it.

1 Like

So, I think I might of found the culprit of why this happened.

As I mentioned originally, I plugged in a new SDR 433 Dongle, Specifically this one’

Nooelec RTL-SDR, FM+DAB, DVB-T USB Stick Set with RTL2832U & R820T

And very shortly after I noticed my Zwave Network was down as I was working through trying pick up some 433 devices.

Well since I got the new Zwave stick and we kind of determined that was the issue. I figured I would give the SDR 433 dongle go again. I downloaded MQTT Explorer, plugged the SDR433 dongle into the same USB hub my Nortek and Zooz Zwave Dongle are plugged into, and within in minutes I noticed my ZHA network was stuck at initializing and my Zwave network went down.

I immediately unplugged my SDR Dongle and I’m restoring to a backup as we speak. You have any idea why this might be happening? I think its safe to say at this point that the SDR dongle is the thing that caused all my issues.

For additional data, I am using a Powered USB Hub, specifically this one

Powered USB Hub 3.0, atolla USB Hub with 4 USB 3.0 Data Ports and 1 USB Smart Charging Port, USB Splitter with Individual Power Switches and 5V/3A Power Adapter

Bought a USB Extension cable plugged the SDR into that, then plugged cable into second port on HA Green vice the Powered USB Hub where my ZHA/ZWAVE sticks are. Been like 10 mins… everything stable…