Zwave-JS Migration Wizard troubles

I’ve been waiting for the migration wizard for a long time. Tried it several times now, and it finds my nodes, but tells me it cannot import any single one of my 50+ nodes with their 300+ entities. Can anyone shed some light on this? Obviously missing a trick or two here :slight_smile:



I too have been awaiting the wizard. Updated HA to the lastest then ran the wizard. Came up and told me I had to stop the network etc, asked me for a device location as in /dev/ttyAMA0 and away it went. Then told me it failed. So as its late in the day I reloaded a backup and will try again another day. Does that failure get logged anywhere so I can see why? I zwave is my original razberry from say 3 or more years ago but everything still works ok. Do I need anew device?

Also failing here, exactly as described by @Secs

Same here. Rolled back to a backup and will stick with the deprecated ZWave for now.

for me I had 91+ entities it apparently couldnt migrate - so I stopped the process right there and rolled back to my backup … unfortunately the backup process didnt seem to work properly either, meaning it didnt come back, I had to hard reboot it after a while to see all services come back …

I actually was less “excited” as this seemed to be an issue during the live demo as well …

Add me to the list, I experienced the same issue trying to use the migration tool. Every single node and entity failed to import. Went back to a backup.

Using Zooz USB Z-Wave Plus S2 stick on a Raspberry Pi 4.

I’m also having issues with the migration. It installs the add-on then reports “failed to connect”. I can see that the add-on is installed and running. I tried specifying the stick by ID and /dev device with the same result, I don’t think it’s having trouble finding the stick. I’m using the Nortek HUSBZB-1.

Hey all, for starters, I too am using a Nortek HUSBZB-1. I did the migration yesterday and it was a bit bumpy, but it was also an awesome opportunity to do some housecleaning.

I have 23 active devices and hundreds of entities. Most of my battery-powered sensors did NOT migrate well and either needed to be woken. I have 7 Ecolink PIR sensors that needed to have their batteries pulled and put back in. I have 3 Zooz 4-in-1 sensors that were very problematic. They needed factory resets and had to be re-included, but they are stable now – really, they are actually way better than with the OZW integration, more responsive. Lastly I have a Yale lock that needed to be factory reset and re-included into the Z-Wave network. It migrated okay, but it came over as an unsecure device.

All in all, the number of entities that won’t come over seem daunting at first, but if you’re like me, you have a ton of them that could probably use a good clean/rename. I am very satisfied this far with Z-WaveJS and I’m glad I went through it. It does seem way more responsive (sensors trigger immediately and the automation is really fast – e.g., lights come on instantaneously now).

Oh, BTW – on the Failed of connect error in the Add-on: Empty all the text boxes and save and reload the add-on. Those boxes will repopulate with correct values. Here I had to reload it again. Once I went into the migration wizard, it connected just fine.

At my end (with 7 devices) migration went mostly fine. One of four identical power switches did not detect properly, ended up as Unknown and had to be excluded and readded.

The one thing I can’t figure out how to replicate in Z-Wave JS is this:

    polling_intensity: 1

My NorthQ Energy Meter never did report regularly without that in OZW and it won’t now with ZW JS.

Thank you, I actually did try with that yesterday. With timing interval set to /3 for three minutes.

Sometime after I gave up on it last night, posted the question here and went to bed, it started working.

Strangely enough at a 5 minute interval. But that could be the 8/WAKEUP interval configured for the device?


i tried today to make migration but is not 100% fine

with zwave js i can’t change entities from switcht to light, on zigbee works great but on zwJS don’t work

I have tried several times also and run into the same issue. It doesnt import any of the entities and does not seem to find all of my devices.



and states that nothing can be imported on that last step before the “Migrate” final step.

+1 same here

Got like 118 devices with 670 entities on the old Zwave

When I did the migration steps I got 60devices with 60 entities nothing worked.

Did put my back-up

Did anyone already had succes migrating?

I’ve got the same issues, many of my nodes not found, and wizard tells me it can’t actually migrate any of my devices… so what’s the point?! I ended up deleting the zwave js integration and will try again when they get this worked out.

The confusing thing to me though is that the migration wizard asks for 4 different keys during zwave js setup. S0, S2, S2 Authorized, S2 Unathorized… I can’t find any explanations anywhere as to what these are… I assume S0 is my old network key, but what about the others… how should I generate them and what should they look like?

S0 is the legacy network key. If you leave any of them blank they’ll be auto-generated.

See that makes sense, but the docs definitely need to be updated to reflect that information. I also gathered from another post I had to dig for that the "0x"s and spaces need to be removed from the S0 key to be in the right format for zwave JS.

Alright, so even with putting in the S0 key with modified formatting and leaving the S2 keys blank, I still get the following error:
“The following entities will not be migrated and might need manual adjustments to your config:”
… This error is followed by a list of entities that contains EVERY single entity in my house… it’s essentially telling me that none of these can be migrated with the wizard…

Anyone know if there’s a fix for this?

My experience
Finally decided to try the migration earlier this month.
Lots of warning and errors. My strategy was to take the plunged and manually fix the issues. Over a period of a few days, was able to get all devices online and renamed - updated automations and all was good for a few days.

Yesterday, noticed that almost all wired devices were marked as Dead. After many failed attempts to correct the situation, decided to roll back to Zwave(Deprecated)

Backstory: Migrated from Vera a few months back to Zooz stick on Pi4. Automations and devices have been stable for months.

I have ~30 zwave devices and most have been flawlessly operating for close to a decade.

I just tried this last night and ran into the same issues migrating. None of my devices were able to be pulled in. Is this user error or should I wait for improvements from the migration tool?