ZWave JS remove Node without exclusion mode

So here’s the checkbox
Uncheck and specify the zwavetomqtt server. Now rebooting to see the results. It works, I allready did a uninstall of the zwave js integration. Now the Zwave-JS addon is not being reinstalled again.

I do have to reconfigure/name the nodes. But I can see that this zwavejstomqtt add-on has some advantages.

If the integration config flow detects that the new instance matches an existing one, it will just replace the configuration settings. It does this by checking the network home ID. This is true for either supervised or non-supervised. If you want to change the hostname for example (such as switching addons), the same procedure works, as long as you’ve moved the same network over to that host.

OK, so the procedure should be “stop the zwavejs add-on -> install the zwavejs2mqtt add-on -> update the integration to use the zwavejs2mqtt add-on using the same zwave controller -> submit”?

and the key is using the same zwave controller for both?

Pretty much.

If you have a separate zwave network, which has a different home ID, it will create a second instance.

1 Like

So the Home ID is based on the controller?

Sorry for all the questions. I just want to make sure I don’t mislead others.

Each z-wave network has a home ID, which is stored by the primary controller. If you hard reset the controller you’ll get a new ID.

OK, thanks.

Hi Guys, I hope you can spend a few seconds helping an amateur. I am running HA Supervised as a container running on a Raspberry Pi 4. I have set up Zwave JS as an integration via Supervisor. I have also set up ZwaveJS2mqtt so that I have better control of the zwave network. I followed the instructions at Z-Wave JS - Home Assistant and both integrations have been running fine. However now I have installed all my zwave devices (77) I am getting the “zwave js cannot lock port” error which is occurring every couple of days. If I reboot the Raspberry Pi the problem goes away for another couple days.
From what you have written, are the instructions given about being able to run both integrations simultaneously incorrect? Even when the instructions are followed ie for the ZwaveJS integration “unselect the Supervisor option and enter ws://core-zwave-js:3000”, and for the ZwaveJS2mqtt integration enabling “WS Server” and disabling “Gateway?
Thank you for your advice.