Zwave multichannel group association

I have some issues regarding multichannel group association with two fibaro smart implants.
currently running ha core in docker with zwave addon (1.4)

what i try to accomplish is to use group association between two smart implants,
si1 input -> si2 output, this should be done by adding si2 to group 2 on si1 but its not working at all.

After much here and there with fibaro support it might seem that the problem is the endpoint (target) for the group command.

according to fibaro the endpoint (target should be 5 for group 2 and 6 for group 3)

when i examine the zwcfg i find this:

			<CommandClass id="142" name="COMMAND_CLASS_MULTI_CHANNEL_ASSOCIATION" version="1" request_flags="5" innif="true">
				<Instance index="1" endpoint="1" />
				<Instance index="2" endpoint="2" />
				<Instance index="3" endpoint="3" />
				<Instance index="4" endpoint="4" />
				<Instance index="5" endpoint="5" />
				<Instance index="6" endpoint="6" />
				<Instance index="7" endpoint="7" />
				<Associations num_groups="3">
					<Group index="1" max_associations="1" label="Lifeline" auto="true" multiInstance="true">
						<Node id="1" />
					<Group index="2" max_associations="5" label="Input IN1" auto="false" multiInstance="true">
						<Node id="10" />
					<Group index="3" max_associations="5" label="Input IN2" auto="false" multiInstance="true" />

it seems to me that index is set to 2 with the correspondig endpoint of 2. this is probably the fault and i need to change the endpoint (target) for group 2 to 5. how can this be done?

Ok this was interesting.

when setting group association by zwave config panel it will default to 0 for target.

First remove the previous association in Group 1 with service: zwave.change_association and JSON:

{"association": "remove", "node_id": NN, "group": 1, "target_node_id":1}

(replace NN with your Node_id)

then call zwave.change_association again with:

{"association": "add", "node_id": NN, "group": 1, "target_node_id":1, "instance":1}

(replace NN with your Node_id)

setting instance id to 5 sorted the issue and group association now works perfectly.

Thanks to Fibaro for good support even though it took 3 months to get reply from them.