ZWave Node Missing Entities

zwave
Tags: #<Tag:0x00007f47fccb1268>

#1

I recently added a GE 14284 Outdoor Smart Switch to my network. First thing I noticed was that the node was discovered and named as “Unknown Node 4” but no issues as it still created a switch entity named “switch.unknown_node_4”. I was able to control my switch with no issues.

After upgrading HA to verison 0.83.2 my node remained but the switch entity was gone. No entities under the node at all.

I tried removing and re-adding the node multiple times, no luck, still no entity.

Here are the steps I took to remove the node/re-add

  1. Set my controller to exclude mode
  2. Activated the switch to remove
  3. Removed the node from my zwcfg file
  4. Restarted (No more node after restart)
  5. Set my controller to add mode
  6. Activated the switch (See the node in HA)
  7. Restart HA

One thing that is odd to me is that the node number keeps incrementing? I’m up to node 6 now. Why wouldn’t it reuse node 4 as this number should no longer be in use?

Back to the main issue at hand.

What can I try to get the entity for this node back?

Maybe the first thing to do is get open z wave updated so that the node is discovered with the proper name/config?

Any ideas would help


#2

I set one up this morning.

I couldn’t get it to work when I tried it adding is using “Add Node” from the zwave config page. I did a a reset on the GE switch and used “Add a secure Node” and it worked.