Zwave on Synology DSM 7?

Update to my issue. I left my volumes in place and simple deleted and reinstalled OpenHAB. I used all my previous Docker settings. I am happy to report its working now but I still have no idea what the root cause was. Appreciate your help Robert.

Patrick, I would ssh into your NAS and check that file exists and if so what are the ownership and permissions on it.

Well it worked for a little while. Its back down again. I’m going to contact Aeotech at this point i am guessing its hardware failure

Thankyou for testing this - I also have the zooz and have been holding off upgrading

Updated and it went pretty smoothly. I did end up doing the 3 modprobe commands.

Hi all,

recently I upgraded my production from 6.2.4 to 7.0 and instantly to 7.1. I use a couple of USB devices:

  • Two USB hubs
  • Aeotec Z-Stick Gen5 (ZW090)
  • HL-340 USB-Serial adapter (zigbee coordinator zzh!)
  • BR1000ELCD (CyberPower UPC)

I am on DS918+. HA with ZWave in VMM but mqtt and zigbee2mqtt in docker containers.

All of the devices showed in zthe information centre but niether the z-vawe nor the zigbee showed in the dev list. I tried all the workarounds listed here (scripts, jadahl drivers, etc.) but none of it worked. Nevertheless I can pass all my USB devices to VM without problems. So I ended up transferring my zigbee2mqtt to HA in VM.

I updated to 7.1.1 from 7.1 and my usb sticks stopped working. I made it work with the modorobe commands listed here in 7.1, but this is not working anymore for me in 7.1.1. Anyone with the same problem?

I just update to 7.1.1 today and my USB stick (deconz conbee) is still working. After re-boot I have a task running with the following:

/sbin/modprobe usbserial
/sbin/modprobe ftdi_sio
/sbin/modprobe cdc-acm 

It runs in Task Scheduler: Control-panel → Task scheduler → user defined script @ boot-up
This might help other USB sticks as well.

Mine is not working with this commands. It is a sonoff zigbee stick.

Are you running HASS in a virtual machine? if so, is the USB stick (still) visible in the virtual machine setup? (Edit-> Others-> USB Device). I have had issue in the past that it was gone after an update.

No, I’m using docker.
I have installed vmm and the device is there. Also in lsusb command in ssh shows the device. But no /dev/ttyUSB0 as i used to have previously.

Same here. I’ve installed USB Drivers from “jadahl com” but this site does not work anymore. In my case lsusb shows the device but it is missing in ls /dev/tty* command

[email protected]:~$ lsusb
|__usb1          1d6b:0002:0404 09  2.00  480MBit/s 0mA 1IF  (Linux 4.4.180+ xhci-hcd xHCI Host Controller 0000:00:15.0) hub
  |__1-1         10c4:ea60:0100 00  2.00   12MBit/s 100mA 1IF  (ITead Sonoff Zigbee 3.0 USB Dongle Plus c0e0b32eeskjnfk34jnk634d73138bba)
  |__1-4         f400:f400:0100 00  2.00  480MBit/s 200mA 1IF  (Synology DiskStation 7F000JR4MS43F299)
|__usb2          1d6b:0003:0404 09  3.00 5000MBit/s 0mA 1IF  (Linux 4.4.180+ xhci-hcd xHCI Host Controller 0000:00:15.0) hub

sometimes USB devices do not show under /dev/ttyUSB* also check for devices under /dev/ttyACM*

I have found that my /lib/modules/cp210x.ko file has 0 bytes. So i guess i have to replace it. Anyone know how to get it for apollolake as jadahl site is down?
As a workaround i have setted a VMM with the usb stick passed to it, with photon os, mounted the original /docker/zigbee2mqtt filder to the VM with CIFS and run docker there. It’s working fine.

I reply myself. I have found the drivers at

Will try them tomorrow.

1 Like

I’ve also found the drivers using the webarchive. They are downloadable Index of /iperf-arp-scan/DSM_7.0

1 Like

I just installed this driver and can confirm that it works

It also worked for me the one I posted.

1 Like