Zwave on Synology DSM 7?

I run both Home Assistant and zwavejs2mqtt in Docker, not in a VM. From what I’ve read, running HA in a VM seems to eliminate the USB serial port problem.

Running a Conbee zigbee stick in VM gives me USB problemens. No problems in recognizing the stick. But after a reboot it is not automatically added tot the VM. I always have to edit the VM, add the stick and than it works. That was the case in DSM 6 and is still the case in DSM 7
Running it in Docker gives no problems at all. It always relaible shows up.

But how often do you reboot? I do it maybe 1-2 times a year.

More often than you think. A DSM update, an VM update, a short power failure.
And from thjat moment on nothing in my hous funtion. I can easely fix it. But when I’m not at home my wife can’t fix it

FYI for other novices - this (dmircea’s post) worked to resolve my restart issue. To be explicit, you have to create the
“modules-load.d” folder

See more:

This worked whereas I couldn’t get the other advertised solution to work (using a
/usr/local/etc/rc.d/ file)


i have a S2 stick 700 Zooz, and try to setup it. i have done also the Marius procedure but i still have error in zwavejs2mqtt:

Driver fail to open serial port…

can you help me figure it out? i have Synology Ds718+ with a Intel celeron


Have you migrated from a working installation on DSM 6.2, or is it a new installation on DSM 7?

This is the Docker image I use:

I think this is the thread that helped me out:

This is some important parts of my settings when installing the zwavejs2mqtt Docker container:

  • Check “Use the same network as Docker Host”
  • Check “Execute container using high privilege”
  • Under “Volume”, I set installation path to “/usr/src/app/store”

Also, here is my settings in the MQTT interface:


thanks for your reply. it is owrking now.


Nice thread , nice work.

1 Like

which Bluetooth USB Dongle do you use? I ve added a TP-Link UB500 Nano Dongle. It shows up in Bluetoothctl with the right Mac Adress, but with “scan on” i cant find any devices.


Bonjour Patrick,

I just bought the Zooz S2 700 Stick and can’t seem to get the serial port working on my Synology NAS 918+. I executed the three recommended commands, disconnected the stick and plugged it back. Nothing. I ssh to the NAS and cannot see the ports.

Looks like you were able to make it work. Do you mind sharing what you did?

Has anyone else used this config with Conbee II and DSM 7 and running HASS in docker?

Hello all,

I used this thread to successfully setup a Zwave Gen5 using Docker and OpenHAB on my DS920+. I simply setup a task on restart to run the modprobe commands. Its been working great for 6 months including a reboot or two. Yesterday I upgraded to the latest Synology version DSM 7.1-42661 Update 2 and now I get a “BRIDGE_OFFLINE” on my controller.

I’ve reran the modprobe commands and also had to add the ch341 and cp210x back into the /lib/modules as they were missing. The synology can see the stick in the info center as well as with lsusb. I can also see it as /dev/ttyACM0 and i’ve deleted and re-added it to openhab many times with no change. I did not change any setting in my openHAB container, it still is set to high access. The only thing that I did was upgrade to the version of Synology i stated above. Anyone have any idea’s? I’ve been trying to figure this out for a few hours now.

dmesg|grep tty I can see the device there too. I’ve verified kernel mods with an lsmod and they are all there. I am at a loss as what to try next. Any suggestions would be greatly appreciated as I am running out of ideas/things to check!

Thank you!

Perhaps related: DSM 7.1 beta compatibility. · Issue #22 · robertklep/dsm7-usb-serial-drivers · GitHub

Hi Robert,

Appreciate the help! The ownership and permissions on the drivers are root:root and 644. I was able to run the insmod and it appears to run without error but i see the same results in OpenHAB. I’ve attached a screenshot.

Also added a screenshot for modprobe. I’m not sure why but when i run the modprobe command against those drivers it cannot find them.

Found this in the kernel logs.

Everything looks okay, to be honest (all the “issues” you see I see as well on my Synology, and for me it works; I run “DSM 7.0.1-42218 Update 3” by the way). You don’t even need the cp210x and ch341 drivers because cdc_acm takes care of your device.

So I have no idea why it’s not working :frowning:

Hi Robert,

Yeah I did some research and also saw that Aeotech advised the cdc_acm was all that is needed. I think my next step is to simply wipe out OpenHAB and set it up again. I dont see how that could be the issue but I am out of ideas. Will let you know if that makes any difference!


i have updated DSM from 7.0 to 7.1 this morning and get a error with my Zen 7 stick in Zwave to MQTT:

river: Failed to open the serial port: Error: No such file or directory, cannot open /dev/ttyUSB0 (ZW0100)

Any help will be welcom