Zwave plus


I have Aeotec Z-stick Gen5 and a Fibaro Motion Sensor in the zwave network so far.
I have options.xml in the same folder as the zwcfg_xxx.xml (/config). I’m using docker.

After installing 0.41 I noticed that, for both, it is saying “is zwave plus - false”.


  1. how can I enable zwave plus (both devices are capable)
  2. can a zwave device route zwave plus? (I will have multiple zwave light switches (powered) and multiple zwave plus motion sensors (battery only)


I have this on OZW_Log.txt:

2017-03-26 11:20:09.376 Always, OpenZwave Version 1.4.2481 Starting Up
2017-03-26 11:20:27.077 Info, Setting Up Provided Network Key for Secure Communications
2017-03-26 11:20:27.077 Info, mgr, Added driver for controller /dev/ttyACM0
2017-03-26 11:20:27.078 Info, Opening controller /dev/ttyACM0
2017-03-26 11:20:27.078 Info, Trying to open serial port /dev/ttyACM0 (attempt 1)
2017-03-26 11:20:27.079 Info, Serial port /dev/ttyACM0 opened (attempt 1)
2017-03-26 11:20:27.079 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
2017-03-26 11:20:27.079 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_MEMORY_GET_ID: 0x01, 0x03, 0x00, 0x20, 0xdc
2017-03-26 11:20:27.079 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_CONTROLLER_CAPABILITIES: 0x01, 0x03, 0x00, 0x05, 0xf9
2017-03-26 11:20:27.079 Detail, contrlr, Queuing (Command) FUNC_ID_SERIAL_API_GET_CAPABILITIES: 0x01, 0x03, 0x00, 0x07, 0xfb
2017-03-26 11:20:27.080 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_SUC_NODE_ID: 0x01, 0x03, 0x00, 0x56, 0xaa

There should be no need to activate it, its something the device simply offers.
HA 0.41 also reports my Z-Stick to be “zwave plus: false” yet it is according to the technical specifications.

Other devices that are plus,are showing up as such though.

So how can I find out if the Fibaro is using Zwave Plus (encryption) or not?

From what I have read Z-Wave Plus only has a benefit if all devices in your network are plus.
Because it’s a mesh network non-plus devices cannot relay for plus-nodes (which will likely fall back to non-plus as a result?).

It could potentially still work if the node has a direct connection possible with the controller. The majority of my nodes are still non-plus, the plus one’s are “added securely” via OZWCP so I assume it uses Z-Wave plus with a direct connection to the controller (since the distance isn’t too far).

Yeah, I’m seeing it replace my Razberry Z-Wave+ controller as non-plus. Some of the devices were securely added, some weren’t, and a couple of them aren’t Z-Wave+ devices.

My own reading suggests that the presence of some non plus devices isn’t a problem.

I seem to have an issue here, too. All of my devices support z-wave plus according to the manufacturers. Also when starting, I get the massage:

Info, Setting Up Provided Network Key for Secure Communications

Yet, says in dev-options, that my z-wave usb controller Me ZME_UZB1 is z-wave plus fase and also the same for some of my fibaro devices. So is there a way to check if secure communication is active and how can I enable it for all devices?

It’s normal for the controller to show up as non-Plus - that one you can ignore. If your other devices are reporting as non-Plus, then they are non-Plus.

As for secure communication - that is device specific and requires that:

  1. You’ve set up the network key
  2. Your device supports it
  3. You’ve used the Add Node Secure option to include it
1 Like

That’s the whole point. Fibaro device is reported to be plus, I have a network key set in the config. I also added the device using “add node secure”.

Z-Wave plus doesn’t mean that encryption is in place - devices can still it, or not, regardless of whether they’re Plus or non-Plus. You need to check whether the device supports it before you try adding it. Once added you can check the attributes to see if it reports as being secured.

1 Like