ZWave Schlage Deadbolt problem with Home Assistant OS + OpenZwave

I recently moved from Home assistant installed on Linux on a rasp3 to the Home Assistant OS.
Everything works like a charm BUT I have a really hard time with my Schlage ZWave deadbolt BE469. It worked very well in secure mode on my previous installation. On Home Assistant OS, I installed the OpenZWave (Beta), configured it with a Network Key, and tried to enroll the BE469 in secure mode. It works but I don’t have the same sensors available. For example, I don’t have the

  • sensor.frontlock_alarm_type
  • sensor.frontlock_alarm_level

Is this a OpenZWave limitation or a configuration problem…
Any Help is very welcome :smiley:

You likely have sensors called access_control and user_code instead now.

Yes exactly ! But User_code shows the user slot number that entered his code but only for a few seconds.
Is there a documentation on how to use this new sensors ? (What’s the use of access_control for ex ?)

No, they’re not new either, they’ve always been there, the zwave integration manipulated the sensors to show you alarm_type and alarm_level.

This is what the alarm_type sensor did, gives you the status of the lock, ie: Keypad Unlock, etc.

You may want to look into the lock-manager integration to manage your lock.

Excellent ! Thank you very much !
I didn’t know that the data was manipulated to show the alarm_level and alarm_type.
I’ll have some more reading and I’ll change my automations according to this
Thanx again !