Zwave set up on home assistant is failing

I have set up and used Home Assistant on my Raspberry pi 4. I started with zigbee, on a conbee ii. Brought in a lot of devices and build automations. Now I am attempting to set up Zwave. I got a Nortek stick. I know it also has zigbee, but do want to move my zigbee devices and redo automations so am planning on leaving them on my conbee ii. I followed the home assistant instructions, editing my config file with

Restarted the HA and went to integrations. Zwave shows up, but when i open it the network doesn’t show up, and this is my log file

2021-01-31 20:50:19.001 Always, OpenZwave Version 1.4.3469 Starting Up
2021-01-31 20:50:23.561 Info, Setting Up Provided Network Key for Secure Communications
2021-01-31 20:50:23.561 Warning, Failed - Network Key Not Set
2021-01-31 20:50:23.562 Info, mgr,     Added driver for controller /dev/ttyAMA0
2021-01-31 20:50:23.562 Info,   Opening controller /dev/ttyAMA0
2021-01-31 20:50:23.562 Info, Trying to open serial port /dev/ttyAMA0 (attempt 1)
2021-01-31 20:50:23.562 Info, Serial port /dev/ttyAMA0 opened (attempt 1)
2021-01-31 20:50:23.563 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
2021-01-31 20:50:23.563 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_MEMORY_GET_ID: 0x01, 0x03, 0x00, 0x20, 0xdc
2021-01-31 20:50:23.563 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_CONTROLLER_CAPABILITIES: 0x01, 0x03, 0x00, 0x05, 0xf9
2021-01-31 20:50:23.563 Detail, contrlr, Queuing (Command) FUNC_ID_SERIAL_API_GET_CAPABILITIES: 0x01, 0x03, 0x00, 0x07, 0xfb
2021-01-31 20:50:23.563 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_SUC_NODE_ID: 0x01, 0x03, 0x00, 0x56, 0xaa
2021-01-31 20:50:23.563 Detail,
2021-01-31 20:50:23.563 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x15) - FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
2021-01-31 20:50:23.563 Detail, contrlr, Notification: DriverFailed

I looked at other threads, and some had you adding a path for the device.

This is my hardware file

  - /dev/ttyACM0
  - >-
  - /dev/ttyUSB0
  - >-
  - /dev/ttyUSB1
  - >-
  - /dev/ttyAMA0
input: []
disk: []
  - gpiochip504
  - gpiochip499
  - gpiochip502
  - gpiochip0
  - /dev/bus/usb/001/001
  - /dev/bus/usb/001/002
  - /dev/bus/usb/001/003
  - /dev/bus/usb/001/004
  - /dev/bus/usb/002/001
  - /dev/bus/usb/002/002
    name: bcm2835_headphonbcm2835 Headphones - bcm2835 Headphones
    type: Headphones
      - chan_id: '0'
        chan_type: digital audio playback

I tried using various paths, but nothing worked.
An additional quick question is where do I get the security key, as apparently I need it for door locks.

Any advice or suggestions would really be appreciated

Where have you set up the Z-Wave integration? Through the UI (Integration) or in configuration.yaml?
If you set it up through the UI you had the option to configure a device path and a network key (if you didn’t manually enter a key it auto generated one)
If you used the configuration.yaml make sure you also set up a network key ( Z-Wave - Home Assistant (

The device paths you can use:

1 Like

Thank you so much, I had tried all sorts of patch but never a long one like that. That did the job :).

1 Like