Zwave status in frontend after update to 36.1

Hi there,

Upgraded from 33.1 to 36.1. Upgrade went well, no errors, all running fine.
Zwave however is a different story. The zwave network is running fine (Aeotec Gen5 stick), all nodes reporting their status. The problem is the states are not updated in HA frontend. Using for example a switch will actually switch the device, as showing in the zwave logs and real status, and the network reports the correct status. HA frontend however switches the state back to the initial state in a few seconds. Tried a few things, rebooted, no go.
Had to revert to snapshots as I couldn’t get it to work.

Anyone seen this before?

By switch you mean a switch entity or light entity?

Yes. For example Fibaro Wallplugs. Which are a binary switch. But also for motion detection by Fibaro Eyes. I see them turn on and off in zwave logs, so they are working. But status isn’t updated in HA.

Not using Fibaro but running 0.36.1 here and seeing state changes immediately on all my Zwave stuff.

Hmm. No clue what’s happening. Logs are clean. And zwave is reporting all good too. Going to retry again later tonight. Will update :slight_smile:

1 Like

Hello,

I have a newly built HAAS ( PI2 / Haspbian / Aeotec Gen5 / Leviton Switch ) with packages up to date. It took a few attempts but I got it to work finally. However, I can not confirm if the Frontend was working prior to upgrading to 36.1 version. What doe happen is: I can control the switch in the UI fine which is awesome. When I manually turn the switch on or off. The front end does not reflect the manual change.

If there is logging or debugging steps I can perform I would gladly do and report back. I am very pleased with this project so far. I look forward to testing.

-tmc

So it looks like the front end doesn’t catch the actual state of the switch in the zwave network. Interesting, since that looks a bit like my situation where the front end switches, does send the command which is picked up and executed by zwave, replied by zwave with the actual state and then the front end thinks the switch hasn’t happened and resets to the previous state.

The difference between our situation is that your scenario doesn’t reset the state if switched in front end.

Ok… Running 0.36.1 now.
What I did:

pip3 install --upgrade --force-reinstall homeassistant

After that I noticed that the frontend, which is proxied by nginx now said “reconnecting”, which it didn’t do when I tried to upgrade previously. Searched a bit and added the following to nginx config:

	proxy_set_header Connection "upgrade";```

Restarted nginx and now it is working fine. Had to upgrade my Hue bridge to get my lights back by the way, but that is off-topic here. :slight_smile:

Let's see how it runs from now on. :thumbsup:

Ok, the new proxy settings don’t work for iOS. It keeps saying “connection lost, reconnecting”. Ideas?

Solved. Using a valid non-self signed cert it works on all browsers, including Safari on iOS.
(using a letsencrypt cert now)