Zwave switches changing on their own

Strong issue here. I ran Domoticz on a Synology NAS with a z-stick for over a year with minimal issues. I wanted to migrate to Home Assistant for a number of reasons, so I bought a Pi, set up Hassbian, and plugged in the stick. I was looking to gain support for my zwave garage door opener, which required compiling the beta version of openzwave.

I couldn’t get it to work and eventually switched over to Ever since, my zwave switches have been acting up. They stopped reporting current status and would turn off/on at random times. I disabled all my automations and it was still happening. Eventually, I just shut down the pi and found the switches turn back on by themselves after I turn them off.

How can I monitor what is triggering the switches? It seems like some of the switches are tied to my motion sensors, but Home Assistant isn’t even running now. I fear that might just have to reset everything and start over.

rPi 3
Aeon Z-stick
3 GE switches
2 Aeon micro switches
1 Aeon multisensor
2 Monoprice motion sensors
2 Monoprice door sensors
3 GoControl bulbs
1 GE outdoor switch

1 Like

Zwave networks can work peer to peer and don’t necessarily need a controller. It looks like your Motion sensors have somehow become associated with the lights and are triggering them. Unfortunately I don’t know how you would go about troubleshooting or fixing this, hopefully someone wiser will come along shortly!

1 Like

I had something similar where somehow one of my lights had paired with a motion sensor. It took a while to diagnose!

I got a tool from Aeon called Zensys. With the following instructions:

  1. Download the Zensys tool which is a debug software that is Windows Exclusive (unfortunately OSX or Linux will not work with this program), you can find the software here:

  2. Close all programs that are linked to the Z-Stick Gen5

  3. Open up the Zensys Tool program

  4. On the toolbar at the top, go to Categories -> Settings

  5. Select the Z-Stick Gen5 which should be labeled as UZB (COMX) where X is a number and click on “Apply”

  6. Now click on “Set as SUC” which is under the 6th icon from the right with NodeID = 1 highlighted.


  1. Now close the program and test the inclusion function again.
1 Like

The easiest way I found to get rid of the associations was to reset my sensor to it’s defaults, that of course means you will probably have to rename it and set it up again tho’ in HA.

Thanks. I pulled the battery from one of the motion sensors and that helped. After a while I noticed some of the switches went off again though. Will try removing the motion sensors individually to see what combination is triggering the issue.

I found your previous thread on this - All Lights somehow paired to motion sensor

After looking in my zwcfg*.xml I found 5 nodes include association with node 255 for some reason (including the two sensors I pulled batteries from). Since I’m running and can’t run OZWCP, I think I’m just going to nuke the whole thing and start fresh by reseting my zstick and re-incluing all the devices.

Pulling batteries doesn’t really accomplish anything. Once a device is paired to a hub, it’s there until excluded. the zwcfg is generated from your device. Run Zensys to remove the association and you should be fine.

Sorry, I wasn’t clear. I just pulled the batteries on the motion/door sensors to confirm that would stop the lights from turning on/off on their own. I don’t have a windows machine here available, so I went ahead and reset my zwave stick. So far it looks like after re-adding devices the associations are gone.

I removed all devices from my zwave network and then re-added them one by one. I checked the zwcfg*.xml after each one and some had some came in with associations for node 1 (“Lifeline”). Everything was working though.

This morning I noticed my outside lights started turning on/off again based on a motion sensor. So I checked zwcfg*.xml again and now three devices (the motion sensor and two light bulbs) have added node 255 under associations. I’m going to try removing those three again, but this is frustrating to say the least. Somehow device associations are being updated, but I can’t figure out how. The zwave config options in don’t let me update associations. I’m likely going to revert back to Hassbian in order to get the zwave control panel back.

If you find that there’s something that only the OZW control panel can do, that the built in Z-Wave control panel can’t, please raise an issue so that it can get looked at.

1 Like

The Z-Wave config options in HA will only let you update associations and config parameters if the device is properly defined in the OpenZWave device library. Z-Wave devices automatically self-describe what command classes they accept (alarm reports, binary switch etc) but not their association groups or configuration parameters. You can manually add devices to the library by describing them in XML. On my system those are in


particularly manufacturer_specific.xml in that folder, and also various XML files in subfolders, one subfolder per device manufacturer. They are probably somewhere slightly different on

This XML needs to be properly set up before you add the device to HA. You’ll need to exclude and re-include the sensors from the Z-Wave control panel after modifying the XML.


Keep in mind that it’s sometimes possible to associate lights with a motion sensor without Home Assistant being involved. Depends on the device. There’s often a button press or similar on the motion sensors to put them into a mode where they’ll associate. Be careful you aren’t doing that when including your motion sensors.

Thanks, I think that might have been causing my issue. Over the weekend I reset everything again and decided to just add my switches to start. Once I’m confident these are working fine as is, I’ll add the light bulbs and then finally motion/door sensors. I also repositioned my pi to a more central location.

After a day it looks like nothing is being triggered unexpectedly. It seems like I’m not getting updates from the switches though, so I likely need to turn on polling.